WordPress.org

Support

Support » Plugins and Hacks » Ultimate Posts Widget » Several Ultimate Posts Widgets when viewing a post entry not working

Several Ultimate Posts Widgets when viewing a post entry not working

Viewing 10 replies - 1 through 10 (of 10 total)
  • I’m having this same issue.
    In addition, if you visit a category that has no posts, all the widgets and their categories will say there are no posts, despite having posts.

    It seems as if the widget is being over-ridden by the selected category.

    Any help/updates would be awesome.

    Looking into the code a bit, the issue is arising because functions such as the_title, and the_permalink, etc. are being used to display the category’s posts. But those functions take their info from the current post which is then being used to populate the widget ouput.

    Unfortunately, I don’t know how to go about fixing the issue, but maybe it will spark something for someone else.

    @bace135, could you tell me in which file and line of code you found this? Might be fixable.

    After looking around, there seem to be something odd at line 128 in ultimate-post-widget.php.
    The call to get_the_category() would return the current posts categories. To be correct, the code should use the category id I told it in the widgets pane in wordpress.

    This might be an incorrect assumption of course, it’s only after a brief look in the code.

    I’m trying to do the same or similar.
    I need to display different post categories on two different Blog Article pages. I have made a new Sidebar to display one set of Blog Categories, the other sidebar (Main) should show a different set of posts – eg different categories.

    There doesn’t seem to be a way to select the category you want to show in each sidebar, making the widget not a great deal better than the WP built in feature.

    As Bace135 says – the function is to display current posts, I was expecting the option to select the post category you need.

    Has anyone got any answers?

    I have the exact same problem. Has anybody found a solution? I do not feel competent to delve in the code myself

    Same problem here. Index view works fine, but the single view is messed up.

    Please fix this issue 🙂

    Same problem here. I have two widgets for two categories but when I enter a post in a category both widgets show articles from only a category, the same of the post.

    esmi

    @esmi

    Forum Moderator

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else’s topic.

    This topic references an old version of WordPress.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Several Ultimate Posts Widgets when viewing a post entry not working’ is closed to new replies.
Skip to toolbar