Support » Plugin: LifterLMS » Several trouble after updating

  • Hello,

    I am having some issues since last update I made.

    First of all, some students are active enrolled, but when tried to access they received message informing that they are not enrolled.
    Those courses do not have any kind of expiration date or something like that.
    I already clear cache from inside the website. I told them to clean their own cache.
    When I access they’re panel to test it, I am able to access the courses. However they can’t. Every day more and more students are complaining about that.

    Other problem refers to editing classes content. Where I already had some content is not showing.

Viewing 15 replies - 31 through 45 (of 49 total)
  • Hello @nrherron ,

    Thank you for your reply.

    Well, I am just as confused as you are. Because theoretically every cache was deleted before I disable it. However, when I disabled the Astra theme I used to use to test it with a standard WP theme, I had already disabled every cache. But even after I reactivate the Astra theme, sometimes the website still shows the standard theme for example. So I don’t know whats is going on. Without caching should every change be noticed right on way?

    Ok then. Thank you, I will try to find someone at that link. Thank you very much

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @0rbita

    Do you still require assistance here? Have you been able to get this resolved with your host?

    If not, could you let me know who your host is so I can do some research on their caching mechanisms?

    Hello @thomasplevy

    Yes, I still need assistance. The host is SiteGround

    Thank you!

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @0rbita,

    As noted in other threads we’re fairly certain that we’re having conflicts on SiteGround where things are still being cached even though caching is “Disabled”.

    I’m working with SiteGround to identify why this is happening and if there’s anything we can do within LifterLMS to make this work better.

    My experience is that this does not happen on other webhosts. We use Pagely for academy.lifterlms.com and there are no issues like this there. Go ahead and register for any of the free courses there and see for yourself.

    We have users across a great many webhosts and in the last few months were seeing a tremendous number of caching-related issues from SiteGround users. I am not recommending you stop using SiteGround. We’re trying to work with them to get this resolved, but I need to be clear that at this time it does appear to be an issue with the servers (from my perspective) and unless someone can prove me wrong by pointing to specific areas of LifterLMS code that are serving cached content incorrectly I can’t fix this without help from SiteGround.

    Thanks for your patience,

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @0rbita,

    We’ve done quite a lot of testing on SiteGround and it seems to me that when caching is disabled on SiteGround things *generally just work without issue*.

    The only issue we’ve really been able to find is that if you enable caching using the SG Optimizer plugin and then *disable the plugin* some of the .htaccess rules that are added by the plugin are *not removed* and then cached items are still served despite caching being (technically) disabled.

    To remedy this you can reenable the SG Optimizer plugin and then disable caching from within the plugin’s settings.

    SiteGround has been really helpful to us and we’ve found that after working with users to *properly* disable caching for logged in users LifterLMS works just fine.

    Could you let me know if this helps you out?

    ALSO: you have quite a few open forum posts here which are all basically caching issues. I’m going to respond to THIS ONE ONLY and close out the other ones. I’d appreciate it if you could respond here instead of multiple times across other posts so that we can discuss caching related issues in a single place with you. Thanks for understanding!

    Hello @thomasplevy

    Thank you very much for your reply.
    Unfortunately, I suppose it does not solve my issues.
    When I open a ticket at SG, the support told me they have already reenabled the SG Optimizer and disable caching for Lifter.
    Let me show you two images with the settings:
    https://ibb.co/BPsPWXT
    https://ibb.co/S3jBSSW
    I guess Lifter is free of caching from SG Optimizer. If there are some different settings I should do there?
    And if that is all correct, then, unfortunately, my issues are the same.
    I tested switching user with some user I had changed the enrollment date at user_postmeta, but I still can not access the course because the system is not “reading” that her enrollment date is different.
    Also, the curriculum of the course should only show to enrolled students, but it appears even to visitants.
    To sum up, my situation is the same.
    Thank you

    Plugin Contributor Rocco Aliberti

    (@d4z_c0nf)

    Hi @0rbita
    the caching you need to disable in the SG Optimizer plugin is the Browser Caching.
    https://imgur.com/a/SOcAaXv

    Hope this helps.

    Hi @d4z_c0nf

    Thank you, but that Browser Caching is already disabled on my website.
    That said, the issues continue the same.

    Thank you

    Plugin Contributor Rocco Aliberti

    (@d4z_c0nf)

    Hi @0rbita
    still on https://www.unioqs.com.br/ ?

    Hello @d4z_c0nf

    Yes, still there

    Plugin Contributor Rocco Aliberti

    (@d4z_c0nf)

    Thanks, I understand.

    I’m looking at you previous message:

    Let me show you two images with the settings:
    https://ibb.co/BPsPWXT

    According to the SG Optimizer Excluding URLs examples, to exclude all your courses from the server side caching you should actually have something like:
    https://www.unioqs.com.br/curso/*
    and NOT
    https://www.unioqs.com.br/curso/
    Although, as stated by the SiteGround’s techs, SG doesn’t serve cached pages to logged in users, so I’m not positive this would fix your issue, but still is something not well configured.

    Oh, I see.
    I have changed it to the correct url.
    So I did switch users with the student I had changed the enrollment date at user_postmeta and the site was not recognizing the new date untill now to test the new setting.
    That particular one was successful. I was able to access the course as if I had change the enrollment date! Wow, that is a victory already.
    Now I asked my problematic students to access the courses and see if they can actually watch the lessons.
    I’ll let you know what they’ll tell me.
    So, after that, aparentely, SG does cache pages to logged in users.
    The other test I had is the curriculum of the course, that should be available only to enrolled users, but even visitors can see it. That continues the same. So not all solved, but the major problem can may be solved.
    Let’s see. When some student get back to me, I’ll post here.
    Thank you very much!

    Hello again @d4z_c0nf

    Well, so I asked my students to test it, but some of them continued not able to access some courses.
    So even thought I had been able to access the course after changing the excluded url to /* my students continue without access.

    Unfortunately the situation is the same then.

    Thank you

    Plugin Contributor Rocco Aliberti

    (@d4z_c0nf)

    Actually I was surprised when you said it worked, because, as the sg’s tech guys said that shouldn’t be the issue…
    I’m sorry to hear the issue is still there :/

    Hi @d4z_c0nf

    Yes, it is sad that it hasn’t worked out 🙁
    Thanks anyway

Viewing 15 replies - 31 through 45 (of 49 total)
  • You must be logged in to reply to this topic.