Support » Plugin: WP Cloudflare Super Page Cache » Several questions related to plugin & Cloudflare

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor Saumya Majumder

    (@isaumya)

    1. I suppose all scripts should be loaded as local files instead of CDN links?
    Example: https://cdn.jsdelivr.net/npm/bootstrap@4.6.0/dist/js/bootstrap.min.js

    – Not necessary but loading files locally gives you the benefit of better caching and faster load due to less external requests and also you can manage the cache control header of the file.

    I checked the response headers and images are set as “Bypass” shouldn’t they be loaded thorough Cloudflare? whats the best I can do for that?

    – Check what’s the value of the cache-control header value of the images

    I remember you told me once there are no render blocking resources with Cloudflare, but I do get render-blocking from Pagespeed for jquery for example. https://www.tomastestart.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1

    – This is your website script and not a script that Cloudflare is adding to your website.

    Thread Starter snippet24

    (@snippet24)

    – This is your website script and not a script that Cloudflare is adding to your website.

    Ahh understood, thanks.

    – Check what’s the value of the cache-control header value of the images

    It says: “private”

    – Not necessary but loading files locally gives you the benefit of better caching and faster load due to less external requests and also you can manage the cache control header of the file.

    In m ignorance, question: why a local request is faster than an external one?

    Plugin Contributor Saumya Majumder

    (@isaumya)

    It says: “private”

    – That means that the cache control value for your images are asking CF not to cache the image. If you are using Apache/Lightspeed server, enable the add browser cache rule option in plugin settings.

    why a local request is faster than an external one?

    – Cause the browser don’t have to make additional requests to an external server to fetch the files.

    Thread Starter snippet24

    (@snippet24)

    That means that the cache control value for your images are asking CF not to cache the image. If you are using Apache/Lightspeed server, enable the add browser cache rule option in plugin settings.

    Alright thanks, question since under “response header” it returns for server “Cloudlfare” how do I check whether the hosting has Litespeed or Apache? Well tested another client website without Cloudflare but same plan, and it says Litespeed, so that may be it.

    Cause the browser don’t have to make additional requests to an external server to fetch the files.

    Understood, and in addition to that Autoptimize plugin can aggregate those scripts as well.

    • This reply was modified 3 months ago by snippet24.
    • This reply was modified 3 months ago by snippet24.
    Thread Starter snippet24

    (@snippet24)

    enable the add browser cache rule option in plugin settings.

    Done I’m getting MISS value now I suppose I have to wait a bit..

    Thread Starter snippet24

    (@snippet24)

    I’m afraid is still indicating “MISS” value. 🙁

    • This reply was modified 3 months ago by snippet24.
    Thread Starter snippet24

    (@snippet24)

    This is what I’m getting:
    https://drive.google.com/file/d/1s7MB72ijUqb523OLSDZzFrHR6JyQXfI0/view?usp=sharing
    what should I do/try to improve it? I did refresh the page as said in the FAQ..

    Plugin Contributor Saumya Majumder

    (@isaumya)

    The first request should be miss and then it will say HIT.
    You should read this article for more in-depth look on how the Cloudflare cache works: https://acnam.com/untold-truths-of-cloudflare-cdn/

    Thread Starter snippet24

    (@snippet24)

    I keep getting MISS value all the time.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    I am seeing HIT here: https://i.imgur.com/1M8fsBb.png

    Thread Starter snippet24

    (@snippet24)

    Thank you!! Okey using “disable cache” option in the network toolbar (as in your screenshot) returns now HIT. Well I was using private mode, but perhaps would be good to point in the FAQ that it requires to use that option? Other than that I consider this topic solved. Thank you 😉

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.