Support » Plugin: PHPEnkoder » Several PHP notices

  • Resolved Rootside

    (@rootside)


    In admin:

    Notice: check_admin_referer was called incorrectly. You should specify a nonce action to be verified by using the first parameter. Please see Debugging in WordPress for more information. (This message was added in version 3.2.) in /…/wp-includes/functions.php on line 3370

    Notice: Undefined index: enk_pt in /…/wp-content/plugins/php-enkoder/enkoder.php on line 104

    (Same for enk_mt – obviously to do with handling input from the two checkboxes in the settings)

    On a page with an ecoded email address:

    Notice: Undefined offset: 1 in /…/wp-content/plugins/php-enkoder/enkoder.php on line 149

    I know notices are not errors, but I thought you might want to know about it.

    https://wordpress.org/plugins/php-enkoder/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author michael_greenberg

    (@michael_greenberg)

    Thank you, I’ll look into these!

    This is actually a pretty big problem for me, because the “undefined offset” notices are appearing on every web page that contains email addresses — and once for each address. Such as here.

    Was not happening two or three months ago when I installed PHPenkoder, and the cp says I have the latest version, so I don’t know what changed.

    Is there anything I can do to make the notices not appear on the web page?

    Edward

    Yes, you can – it looks like you switched on the debug mode on your site:

    define('WP_DEBUG', true);

    in wp-config.php

    Just set it to false, and these notices won’t appear. You should only set it to true when you develop or test a site.

    Rootside, thanks — that was it. I sure don’t remember doing it and have no idea why I would have, but it’s been almost three months since I installed the plugins, and someone else has been working on content since then. Anyway, turning off debug mode fixed it.

    Thanks again,

    Edward

    Plugin Author michael_greenberg

    (@michael_greenberg)

    Glad you found a way to turn off the messages! I haven’t had time to look at this, but I’ll try to clear this up when I get the chance.

    Plugin Author michael_greenberg

    (@michael_greenberg)

    I just pushed version 1.13, which should get rid of these notices. Thanks again, Rootside, for pointing these out. My tests are running fine, but they are surely inadequate. Please let me know if there are any problems, either here or via email.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Several PHP notices’ is closed to new replies.