Support » Plugin: Simple Share Buttons Adder » Several ‘PHP Notice: Undefined index:’ in 7.3.8

  • halfgaar

    (@halfgaar)


    I can’t save my settings in 7.3.8, so I can’t enable the button. When I try to save settings, the debug log shows:

    
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_plus_share_count_once in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 522
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_share_share_count_once in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 533
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_plus_link_to_ssb in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 618
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_share_link_to_ssb in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 629
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_plus_share_new_window in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 662
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_share_share_new_window in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 673
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_plus_email_message in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 761
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_share_email_message in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 772
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_plus_twitter_text in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 866
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_share_twitter_text in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 877
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_plus_flattr_user_id in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 899
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_share_flattr_user_id in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 910
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_plus_flattr_url in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 932
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_share_flattr_url in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 943
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_plus_buffer_text in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 965
    [26-Oct-2017 12:41:59 UTC] PHP Notice:  Undefined index: ssba_share_buffer_text in /var/www/wordpress/wp-content/plugins/simple-share-buttons-adder/php/class-admin-panel.php on line 976
    
    
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Simple Share

    (@davidoffneal)

    We’re sorry for this inconvenience. While your settings should still be able to save regardless of the undefined indexes, we will be pushing out an update 7.3.9 later today with those notices addressed. Thanks for your patients.

    While your settings should still be able to save regardless of the undefined indexes,

    I actually can’t. When I try, the toggles all revert back to off.

    Plugin Author Simple Share

    (@davidoffneal)

    Hi @halfgaar,

    Thanks for letting us know.
    Can you write to us privately via our email at support@simplesharebuttons.com and send us a login so we can check on our own? We’re trying to replicate the issue but we aren’t seeing on our end.

    Thanks and looking forward to helping!

    Thanks for the offer, but in this situation I can’t do this, I’m afraid.

    By now I have version 7.3.9. I did notice the saving still makes the settings revert (all sliding-checkboxes where to show the buttons are disabled), however, if I reload the page, the sliding-checkboxes I enabled then are enabled. I’m not sure if that was the case with 7.3.8 as well.

    I would assume you don’t have that issue?

    Plugin Author Simple Share

    (@davidoffneal)

    Hi @halfgaar,

    Thanks for reaching out and no problem with the login access.
    We have found a solution for the issue you reported, it seems that the issue was related to users within Firefox. We’ve released an update and it should now be saving.
    Let us know if you have any further problems.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.