Support » Fixing WordPress » Several issues after update from 3.5.2 to 4.5.3

  • Resolved brnrds

    (@brnrds)


    I’m trying to restore a WordPress + WP e-Commerce instance, damaged after a WordPress update: http://realitystudio.de

    I didn’t develop the site nor theme, the person who did is currently abroad and unable to work on this. He made a few attempts at reverting to previous versions of WP, only to encounter some of the issues I have. Gathered some information which I’ll list below, before getting to the issues and what has been done.

    The WP version prior to the update to 4.5.3 was 3.5.2, and WP e-Commerce hasn’t been updated and is at 3.9.1. Database version is currently at 36686. This is not a multi-site/network configuration. Hosted on dreamhost.

    The plugins currently active are:

    addthis/addthis_social_widget.php
    ajax-thumbnail-rebuild/ajax-thumbnail-rebuild.php
    column-shortcodes/column-shortcodes.php
    instant-gallery/instant-gallery.php
    mailchimp/mailchimp.php
    meta-box/meta-box.php
    page-links-to/page-links-to.php
    portfolio-slideshow-pro/portfolio-slideshow-pro.php
    updraftplus/updraftplus.php
    velvet-blues-update-urls/velvet-blues-update-urls.php
    wordpress-importer/wordpress-importer.php
    wp-e-commerce/wp-shopping-cart.php
    wp-old-post-date-remover/wp-old-post-date-remover.php
    wp-smtp/wp-smtp.php
    wpec-prevent-duplicate-charges.php_/wpec-prevent-duplicate-charges.php

    The issues detected up to now are the following:

    – logging into wp-admin with an administrator account would generate a “You do not have sufficient permissions to access this page.” error page. This was partially resolved using this script https://gist.github.com/collegeman/1120221, but not all options are available at this point, namely installing and updating plugins and themes, as well as managing user accounts, even with an admin role user logged in.

    – the front-end is badly disfigured, particularly navigation. After an email exchange with the developer of the (non-child) theme, he said that the theme is strictly based on the WP Codex;

    – the shop at realitystudio.de/shop is out of order, namely, the UI hangs upon clicking an item. Since it stops working this early in the flow, I have no way of testing the remaining steps;

    The steps taken up to this point:

    – (original developer) Try to revert copies of the instance to previous versions of WP. This partially worked, but still led to the issue of a “limited” wp-admin I previously referred to;

    – (original developer) Try to manually add a new admin role user, as per https://www.wpwhitesecurity.com/wordpress-tutorial/manually-add-wordpress-user-administrator-role-wordpress-database/, didn’t work;

    – (me) Run the aforementioned script, which executes wp-admin/upgrade-functions.php functions. This made the “You do not have sufficient permissions to access this page.” error page go away, but led to the “limited wp-admin” issue;

    – (me) SSH’ing in and running database repair commands via wp-cli. No effect.

    Planned course of action:

    If all else fails, try to manually activate wp-export via DB to get content out and work on a localhost instance of this, until it’s ready to go live. I haven’t access to the dreamhost account on my computer, and would have to try this at the client’s office next week.

    Any ideas on how to salvage the current instance would be greatly appreciated. At the very least, if anyone knows the syntax for the array entries in wp-options/active-plugins (can’t figure out the the “s” property) so that i can actually activate wp-export, I’d be very thankful.

    Thanks for reading.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    Do you currently have a backup of the site prior to the upgrade (both files and database) that you can restore from?

    I’m afraid not, only the files.

    Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    Ok, then there’s no way to go back from before then, so let’s see if we can move forward at least.

    Try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue (theme functions can interfere like plugins).

    Sorry for the delay.

    Set up a local MAMP version of the same problematic install, just deleted “.htaccess” and ran

    UPDATE wp_ukq8td_options SET option_value = replace(option_value, 'http://www.realitystudio.de', 'http://localhost:8888/realitystudio-production') WHERE option_name = 'home' OR option_name = 'siteurl';

    as well as https://gist.github.com/collegeman/1120221

    I do have Dashboard access, just not “full-fledged”. Deactivated all plugins and activated Twentyfourteen, problem persists.

    Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    Ok, so it sounds then like your account may have lost admin privileges for some reason.

    If you are not using Multisite, access your database via phpMyAdmin (most hosting providers offer this in their control panel), go to the wp_users table and find the row for your user_login . Note the ID of this row. Now, go to the wp_usermeta table and find the wp_capabilities row for your user_id . Set the value of this row to:

    a:1:{s:13:"administrator";b:1;}

    Thanks for your reply.

    I had actually tried this before, and it didn’t work. To try to clarify what’s happening, I included a couple of screenshots below.

    This is the admin interface of a clean local install, with current versions of the plugins used in the affected site. WordPress export isn’t explicitly installed, but the option is still there.

    This is the admin interface of a local clone of the affected site. WordPress export is installed, activated, but still the option is unavailable.

    This happens regardless if all other plugins are active of not. One extra bit of information that had not been clearly stated is that the database used a non-standard table prefix, if it’s relevant.

    Thanks.

    Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    So, the export option under Tools isn’t a plugin, it’s actually a built-in WordPress feature, but only available to Administrators: https://codex.wordpress.org/Tools_Export_Screen

    And, as you can see from the screenshot there, you’re missing a whole lot more.

    I see you have Updraft Plus installed. Was that installed before the update? If so, the last backup from it should contain the database.

    If not, try downloading WordPress again, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and delete then replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings.

    Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    Did this on a MAMP clone of the troublesome instance, problem persists.

    Thanks for replying.

    Edit: regarding updraft, checking with the original developer.

    Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    At this point, I’m going to have to suggest getting the original developer involved. Based on your screenshots, your copy of WordPress was heavily customized, so at this point it’s pretty much impossible to tell what has gone wrong and why.

    Success!

    One of the Updraft Plus db backups worked. For some reason that db version was for WP 4.0.11, so I downloaded that, created a new database, ran WP install, replaced wp-content, restored the backup, and all seems to be well.

    I agree with it being difficult to figure out what was wrong. Leaning towards issues with WP eCommerce after the db update + the non-default table prefix. Might be wrong. If this didn’t work starting from scratch would probably be best, but with this much content, it’d probably take ages.

    Marking this as resolved.

    edit:

    made a couple of test runs in MAMP, and found that actually running WP install in a new db and only then running Updraft Plus restore means that the default table prefix is used, because Updraft Plus replaces it.

    It just struck me that export was there all along, even in the damaged instance: http://wp-cli.org/commands/export/

    *headslap*

    Thank you, James Huff.

    Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    Awesome, I’m glad it’s working now! 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Several issues after update from 3.5.2 to 4.5.3’ is closed to new replies.