Support » Plugin: Fast Velocity Minify » Several HTML minifying bugs after last update

  • Resolved sublines

    (@sublines)


    Hi, thanks for making and maintaining this great plugin!
    Since the last update however, a few things got messy since the html minifying now strips all urls of its “http:” or “https:”.

    This also happens when the option “Use the dynamic “//” protocol” is not used.
    It only occurs when HTML minification is switched on.

    The problems caused by this are numerous.
    Example: The twitter image used when sharing a link doesnt work anymore, because it can not read the URL of the image.

    I hope you can remove this function from the HTML minification in your next update. I cant use it until then.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Raul P.

    (@alignak)

    I have done a rollback on 2.2.8 with some minor bug fixes only, and will be looking at the other issues at a later time. Sorry and please update.

    Hi Raul, thanks for the reply and quick action!

    I had deactivated the HTML minification in your plugin settings after the bug occured and installed the MINIFY HTML plugin instead which solved the issues.

    In that plugin, I noticed that you can select the following options:
    “Remove relative domain from internal URLs” and “Remove schemes (HTTP: and HTTPS:) from all URLs”.
    Both are deactivated by default and my guess is that activating them would cause the same problems as your plugin did in the previous version.

    Maybe you can add these options to your plugin as well so people can deactivate them if they cause problems for them.

    Thanks again and keep up the good work!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Several HTML minifying bugs after last update’ is closed to new replies.