WordPress.org

Ready to get started?Download WordPress

Forums

Several Errors after Upgraded (Dashboard and deleting) (9 posts)

  1. Marque
    Member
    Posted 7 years ago #

    After I upgraded last night, I can no longer delete comments, posts, or pages, etc...it comes up with this error:

    cf5ii=(IsObject(CreateObject("ShockwaveFlash.ShockwaveFlash.5"))):cf6ii=(IsObject(CreateObject("ShockwaveFlash.ShockwaveFlash.6"))):cf7ii=(IsObject(CreateObject("ShockwaveFlash.ShockwaveFlash.7"))):if (typeof(cfla449568)=="number") {cfla449568=2;}else{cfla449568=1;}if (cf5ii==0 && cf6ii==0 && cf7ii==0) {if (navigator.plugins && navigator.plugins['Shockwave Flash']) {sfVrsAr=navigator.plugins['Shockwave Flash'].description.split(' ');sfVrsAr=sfVrsAr[2].split('.');sfVrs=sfVrsAr[0];if (sfVrs>=7) {cfv=7;} else if (sfVrs>=6) {cfv=6;} else if (sfVrs>=5) {cfv=5;}}}else{if (cf5ii) {cfv=5;}if (cf6ii) {cfv=6;}if (cf7ii) {cfv=7;}}if (cfv!=0 && cfla449568==1) {var cfrl="http://six.flash-gear.com/ncnt/cnt.php?c=jc&bm=0&v="+cfv+"&j=1179695748975079&t="+Math.random()+"&id=449568&a=1131741867";document.write(' <'+'/EMBED><'+'/OBJECT>');} else {if(typeof(screen)=="object"){document.write('');}}

    I have no clue why it does that every time I press delete.

    Also the layout of my dashboard is severely messed up:

    http://img.photobucket.com/albums/v356/markonfire/layoutmessedup.jpg

  2. Marque
    Member
    Posted 7 years ago #

    Still having the problem.

  3. Marcel Brinkkemper
    Member
    Posted 7 years ago #

    @Marque, do you have any plugin to use Shockwave Flash on your site? This may cause the first problem.
    Your messed up dashboard could be the same as this problem: http://wordpress.org/support/topic/117993?replies=25

  4. Marque
    Member
    Posted 7 years ago #

    Yes, I do use a Shockwave flash plugin.

    <insert time for checking of , downloading of, and upgrading of plugins>

    Ok so, yea...that was the problem. I need to upgrade...

    And now I have a problem that is rather quite hilarious, I thought. When I am pressing the "delete comment" button...

    It trys to take me to http://www.themarque.org/wp-admin/ocomment.php?action=deletecomment&p=157&c=16754&_wpnonce=f89cb4959f

    Notice the "o" in before comment.php. Now how in the world did that get in there? It's like that in everyone...

  5. Marcel Brinkkemper
    Member
    Posted 7 years ago #

    Marque,
    I can't say where that "o" came from but it should not be there. I recommend that you download a new install from WordPress http://wordpress.org/download/
    Delete all wordpress files from your site and re-install the lot.
    Also check if the permission of your directories and files are "save" e.g. chmod 755 for directories and chmod 644 for files.

  6. Grumpysteen
    Member
    Posted 7 years ago #

    I ran into the same thing recently.

    Edit wp-admin\admin-functions.php and search for "ocomment.php" and you'll find one instance which needs to be changed to "comment.php" Once you've saved that change on your site, deleting will work again.

  7. Marque
    Member
    Posted 7 years ago #

    Works. Thanks.

  8. Marcel Brinkkemper
    Member
    Posted 7 years ago #

    @Grumpysteen and Marque,
    Those changes and the ocomment.php are probably uploaded by hackers. Please check your file and directory permissions to prevent it from happening again.

  9. Grumpysteen
    Member
    Posted 7 years ago #

    No hackers and ocomment.php doesn't exist.

    I was setting up a fresh install on a new site from http://svn.automattic.com/wordpress/trunk/ using subversion.

    It's just a typo in admin-functions.php that added an o to a reference to comments.php

Topic Closed

This topic has been closed to new replies.

About this Topic