Support » Plugin: BulletProof Security » Several bugs that effect all users, refusing to fix & rude support…

  • I posted on their forum for some support to try and get two bugs fixed as it was a very minor annoyance to me but could effect other people in a negative way, especially the second of the two main bugs.

    I was met with links to some “guides” that that I had already read and couldn’t help me at all with the issues.

    I replied explaining that it is in their interest to fix them as two of the main bugs are global bugs that could effect others and for me personally it wouldn’t make a huge difference if they didn’t fix them but I was willing to work with them to get a fix for my minor annoyance and potentially a major problem for other people.

    They replied again saying that they couldn’t help any more with the free plugin support (seems a no brainer to me, why wouldn’t you want to fix a bug could effect any of their users.)

    Certainly not a wise way to “entice” people into buying their “pro” version. and then to top it off, they replied with “We already what you were up to. Your account has been deleted.” for some reason… I was actually considering purchasing their pro version just to get the minor annoyance fixed and request a very small feature but that move cemented my decision into not purchasing their pro version, giving this bad review and finally uninstalling their plugin.

    Fantastic way to lose someone who is genuinely trying to help them, their members while getting a very small reward from it.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author AITpro

    (@aitpro)

    We were working with you and you became extremely abusive/rude/disrespectful/attacking so we decided not to continue helping you. Sorry, but we have new firm zero tolerance policy about that now.

    What you are claiming are bugs in BPS that would affect everyone/anyone else are not bugs in BPS code. Whatever problems that are/were occurring on your website/server were only occurring on your website/server and not for anyone else.

    Hi,

    I wasn’t in any way abusive, rude, disrespectful or attacking… you’ve even gone and deleted the thread on your website so I can not prove my innocence which in effect shows that I was innocent. Which you and I both know that I wasn’t any of those things.

    Bug 1: This bug can be easily replicated on any wordpress sever that has a SSL certificate.

    Which is a tiny, minor bug that is widely applicable to anyone who forces non-www and forces https so yes, it is a bug that can effect anyone and everyone that uses BPS. If someone has a SSL certificate for website.com but not the www. subdomain (yes these ssl certs exist, for example the new “letsencrypt” certs) then this effects them straight away.

    As for Bug 2 it’s a lot harder to explain as it’s a lot more complicated and would need to be done via a video for it to make sense and done privately to you for security reasons but you clearly don’t want to fix bugs with your software.

    Instead you lie about me saying that I was rude, abusive, disrespectful and attacking when you and I both know that I wasn’t.

    Plugin Author AITpro

    (@aitpro)

    Not going get into who believes they are right or wrong since it is not productive. I believe the issue may be that there is some sort of compatibility thing going like certain customizations, constants or other settings just don’t work for what you are trying to do. Not really sure to tell you the truth.

    Plugin Author AITpro

    (@aitpro)

    Maybe this plugin is what you are looking for: https://wordpress.org/plugins/wordpress-https/

    Hi,

    It’s nothing to do with any customizations or plugins because I’ve tried two different webhosts and even two fresh installations, issue happens on all.

    Nope, that plugin doesn’t resolve the problem either. It’s 100% clear that your.htaccess files cause the issue and because it’s a small one hardly anyone will notice, although anyone with a non-www ssl cert could easily find it and

    Plugin Author AITpro

    (@aitpro)

    Ok well sorry it didn’t work out.

    Thank you, Hyflex. I was planing to buy Bullet Proof Pro, but since it seems to cause issues with a https website and due to the pure arrogance / ignorance of the AITpro support I am not going to spend any money for that plugin.

    PS: You can have the best plugin in the world, but if your support sucks…

    Plugin Author AITpro

    (@aitpro)

    @mrmeeeseeks – hmm so you are only going to look at this 1 person’s opinion instead of looking at all of the Reviews? We offer outstanding support. Don’t take my word for it. Start at the beginning of the Forum Review section and you will see a common theme/pattern – The majority of folks point out that we offer awesome support. You will also find that same theme/pattern pretty much everywhere you look. ie our site and general google searches.

    It is fairly rare when we run into this type of argumentative situation like the one we had with Hyflex. We basically just try to difuse situations like these because otherwise they will undoubtly escalate and continue and usually there is not any sort of resolution. So it is better just to back away from “it”. We know this from years of experience with this type of situation.

    BPS and BPS Pro work fine on https sites. One of our sites is https and 1,000’s of our customers sites are https.

    • This reply was modified 2 years, 11 months ago by  AITpro.
    • This reply was modified 2 years, 11 months ago by  AITpro.
    Plugin Author AITpro

    (@aitpro)

    @mrmeeeseeks – Oh and if you would like to test BPS and HTTPS and see for yourself then use the HTTPS/SSL htaccess code that we created here for HTTPS/SSL websites: http://forum.ait-pro.com/forums/topic/wordpress-ssl-htaccess-code-rewrite-ssl-rewritecond-server_port/#post-7233

    • This reply was modified 2 years, 11 months ago by  AITpro.

    This is their standard defense when a user actually discovers a flaw that they cannot fix. The call the user names and accuse him/her of being abusive. For all of you folks using this plugin, I cannot stress strongly enough that you need to install Wordfence free version (at a minimum) and run one scan to see how many missing or corrupt files you actually have because of this malware.

    Plugin Author AITpro

    (@aitpro)

    @tclaffy – We just try to stick with facts and valid information, but thanks for your opinion. I’m sorry you are still angry with us. Most of the time things go great and everyone is happy. Obviously that did not happen between you and us. So sorry about that man. It is what it is. 😉

    • This reply was modified 2 years, 5 months ago by  AITpro.
    • This reply was modified 2 years, 5 months ago by  AITpro.

    Since this has been going on for over a year now I think we’ve reached the end of having a productive discussion here. I’m closing this topic.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Several bugs that effect all users, refusing to fix & rude support…’ is closed to new replies.