Support » Themes and Templates » Setup Problem – Cannot Install Themes

  • Hi everyone,

    I’m the only IT guy at my company, and we have installed WordPress on our webserver (IIS 6). I followed the 5 minute installation and everything went great. Except until the person setting up this site tried to upload a theme. This is the error we get:

    Unable to create directory wp-content/uploads/2013/02. Is its parent directory writable by the server?

    I’ve searched for this error, and all I can find is information about setting the permissions to 777. I’ll confess that I have absolutely no idea what that means. What permissions? It occurred to me that maybe I need to set up FTP access to the wordpress directory, but I can find no such spot in wordpress to identify an FTP server/login.

    I’ve also heard that it could be an issue with the file size, however I have verified that the file is below the limit set in php.ini.

    Any help is greatly appreciated. Thank you!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The “permissions” that it’s talking about are the permissions that the server sets on a file or folder to determine what users can read, write and execute that file/folder.

    Servers work differently to your normal desktop PC. Every file is set to allow or dissallow access by specific groups, users or the general public. In your case, the folder at /wp-content/uploads/ is set so that the web server user doesn’t have write permissions on that folder. That ensures that they can’t create or update files in that directory – which is why your installation fails when it tries to write the new files.

    There are settings in IIS for this, but I can’t help you much with this as I really haven’t used IIS before, but knowing Windows, it should either be a right-click on that folder in the exploroer, or there will be a command that you cna enter on the command line to fix this issue.

    You also have the option of doing manual installs and updates by downloading the pluign/theme files and copying them into the corresponding folders on your server.

    Hi Thomas – it sounds like your /wp-content folder or /uploads folder is not set to the right permissions.

    Before changing folder permissions, you should also check this article for reference – it’s a really good points of reference :

    Also – take a look at this article for WordPress security – it’ll also reference file/folder permissions :

    Thanks Jakilevy!

    The articles definitely help. I think I’m still missing something though.
    First of all, there is no /uploads folder in in my /wp-content/ folder.
    Secondly, the file permissions article talks about the “user (ftp) account.” I have not set up any FTP for WordPress because there was nothing in the installation instructions about setting up an FTP.

    I’m pretty sure there is SOMETHING that needs to be done with FTP, but I can’t find any information about it.

    It seems like there is not a lot of documentation for people who own their own Windows hardware on how to set up WordPress. I sincerely apologize if I’m being dense… I’m usually pretty good with this stuff, but this has me baffled.

    Any further help with the FTP issue is greatly appreciated!

    FTP is not part of WP – just a way to access files on a server – see:

    Make sure you have write permissions to directory wp-content/uploads/2013/02 or you can create these directories manualy.

    Thanks guys, I finally got it working. It took some playing around with the permissions to figure out which group would cover WordPress without giving Full Control to everyone and their mother.

    Thanks again for your help!

    Hey Thomas – for reference, the /uploads folder doesn’t get created until you upload something via wp-admin (when you’re logged into your WordPress site). That said, you won’t be able to upload anything if your permissions are off – so it’s a bit of a catch 22.

    When you get a chance, let us know some more of your systems info and what you did to solve things – this could help someone else down the line.

    Glad you got it working!

    Thanks again Jakilevy! I ended up giving “Full Control” permissions to the “Users (local server\users)” group for the wp-content folder.

    I’m still interested in learning WHICH user account is actually being utilized for WordPress. Intuition tells me that it is the system account, but this account had Full Control already, so obviously it was not the culprit.

    That being said, I’m not interested in testing every user account on this particular server, so I may be forced to wonder.

    Thanks again for your help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Setup Problem – Cannot Install Themes’ is closed to new replies.