Support » Fixing WordPress » "settings" vanished


  • well, it is a neglected blog… got over 3000 spam comments in pending over the last year. went to control panel to just shut off comments and found that “settings” altogether is gone from the left hand. it is just(from top to bottom): dashboard, posts, media, comments, profile and tools.

    I guess I was hacked?

    Also, is there any way I can delete all 3000 pending spam comments in one click? Many thanks!

    .

Viewing 3 replies - 1 through 3 (of 3 total)
  • There should be an “Empty Spam” at the top of you spam list. It also appears that the username you are logged in as is not an Administrator login. Probably an Editor or Author status.

    and run a virus check

    http://sitecheck.sucuri.net/scanner/

    .
    1. Ok you were right, I was logging in as author
    2. They are comments, not spam, so I cant use that button 🙁 … and this is another thing that makes no sense:

    I have the two choices below selected:
    >Comment author must fill out name and e-mail
    >Users must be registered and logged in to comment
    However, I only have 20 legit subscribers, but practically all 3000 comments are from non registered (spambot) users…. why/how?

    Thanks again

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘"settings" vanished’ is closed to new replies.