• Resolved petebm

    (@petebm)


    Hi

    This plugin looks like just what I need – but settings updates are either taking a loing time or not happening. I changed the font & background colours, and that has now, after a long time, shown on the site, but I also enabled the CCPA and GDPR setting, but then changed back to just GDPR and now the ‘Do not sell my personal imformation’ still shows. I really don’t want that, so tried resetting the plugin to defaults – still there; deleted the plugin – banner disappeared – reinstalled plugin, banner came back, complete with CCPA line. I’ve cleared the host Litespeed cache, and tried a different browser – still there.

    Is there any way I can force changes like that to show straightaway? The plugin is currently deleted so users don’t get that message.

    Thank you

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter petebm

    (@petebm)

    Update – I have been ‘playing’ with the plugin on a staging site, test.rileyrmclub.org.uk. There, changes to settings are having an effect, but strangely if I check the same site in a Private Browsing window I still get the default settings.
    I haven’t dared enable the CCPA option on that site . . .

    Thread Starter petebm

    (@petebm)

    Update 2

    It seems as though I only get the correct settings if I view the site while logged in to WordPress; I thought everything was working OK, and the notice was appearing as shown here – but when I tried a couple of different computers, and asked another user, it was still showing the notice with the CCPA option. Which makes me wonder where it’s picking up that setting from – when I deleted it, I looked in cPanel File Manager, and there was no plugin folder left to contain any settings.

    Turning the message off doesn’t seem to affect it, nor disabling the plugin, so I’ve deleted it again.

    Plugin Author webtoffee

    (@webtoffee)

    Hi @petebm,

    Greetings from Webtoffee!

    From all of your explanations, we are fairly certain that this is a caching issue. As all the changes are made in the front end, you must clear the site cache from the site and from the server(if you have any server-side caching) to reflect the same.

    You are able to see all changes when logged in as admin because caching is normally disabled for admin users since they are the ones most likely to make editing in the site.

    Thread Starter petebm

    (@petebm)

    Hi @webtoffee

    Thank you! I thought it must be a caching issue, but thought clearing the server cache was enough; I was wrong, a Litespeed plugin on the site also needed clearing. Problem solved, new cookie notice in place, complete with edits. Brilliant.

    5 star review to follow . . .

    Pete

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Settings update not happening’ is closed to new replies.