Support » Plugin: WooCommerce Square » Settings Tab is Missing

  • Resolved metalandcoffee

    (@metalandcoffee)


    I’ve recently updated to WooCommerce 3.7.0 and the settings tab for Square is now missing. I’m on WooCommerce Square version 2.0.1. I was wondering if anyone else has this issue.

    I am currently getting this error that I am unable to fix due to the tab being missing.

    “Heads up! There may be a problem with your connection to Square. In order to continue accepting payments, please disconnect and re-connect your site.”

Viewing 12 replies - 1 through 12 (of 12 total)
  • I had the same problem. I’m reverting sites back to WC 3.6.5 till this is sorted.

    I have the same problem! After the update, it requested to disconnect and reconnect. It doesn’t show up as a tab in Woocommerce setting now. Help!

    Same here. Square has been working– but that ominous message, “Heads up! There may be a problem with your connection to Square. In order to continue accepting payments, please disconnect and re-connect your site.” keeps showing up. Sometimes it alternates with background processing not happening, too. We have been able to keep processing payments (or seem to be) but why would it just stop doing background processing?!?!?! I have enough to do without messing around with this fickle stuff.

    • This reply was modified 2 months, 1 week ago by  zccreate.

    I noticed this last night as well. This is a fairly new store so I haven’t seen if square processing is actually working. I can only hope when someone goes to buy that it functions. It appears to be, and with no way to test the connection or if it’s functional (without making a purchase) I guess we wait and see? Can we at least get answer from someone about the ominous message. This is quite annoying and time wasting, possible income loss.

    Edit: This is the response I just got from Woo support

    Hi, thanks for reaching out. You are right, testing with a purchase and checking the logs is the way you would test to see that it’s working. Unfortunately the current version of Square has a few bugs and we are suggesting that you roll back to the previous version of Square.

    Practically speaking, we recommend the following:
    1. Making a full backup of your website (files & database)
    2. Downloading Square for WooCommerce 1.0.38 from your WooCommerce dashboard at https://woocommerce.com/my-account/downloads/ or directly at https://wordpress.org/plugins/woocommerce-square/
    3. Logging into your site and navigating to Plugins > All plugins
    4. Disabling and deleting Square for WooCommerce 2.0.1
    5. Reinstalling Square for WooCommerce 1.0.38 and activating it

    • This reply was modified 2 months, 1 week ago by  swoods93631. Reason: added info

    Just an update and response to Swoods93631, we are still able to receive payments through our site even with the ominous warning lingering at the top of the WP dashboard.

    Plugin Support Mike W

    (@nixiack8)

    Hi All!

    If you are still on Ver. 2.0.1 this is replicable, and it is one of the many reasons we pulled 2.0 and 2.0.1 and are working towards 2.0.2. If you are still on 2.0.1, then @swoods93631‘s answer from us is the official one.

    Normally we would recommend disconnecting from Square, so when you have uninstalled the 2.0.1 and reverted back to 1.0.38 clear your server cache to make sure it is not still ‘connected’ to Square. This can cause further complications.

    Please do the following:

    1. Making a full backup of your website (files & database)
    2. Downloading Square for WooCommerce 1.0.38 from your WooCommerce dashboard at https://woocommerce.com/my-account/downloads/ or directly at https://wordpress.org/plugins/woocommerce-square/
    3. Logging into your site and navigating to Plugins > All plugins
    4. Disabling and deleting Square for WooCommerce 2.0.1
    5. Reinstalling Square for WooCommerce 1.0.38 and activating it

    Please let me know if these steps are not working!

    gaffmedic

    (@gaffmedic)

    This did not work for me. I reinstalled and activated. There are no settings at all. I don’t even see the option to connect or disconnect square.

    rhinedesign

    (@rhinedesign)

    I have the same thing, i stuck with 2.0.0 waiting for 2.0.2 and it’s still processing payments. But inventory quit syncing up from square once that notification hit and can’t access the square settings, is there a way in the database to manually enable the settings tab so i can force another inventory sync?

    gaffmedic

    (@gaffmedic)

    I disabled square and will process with paypal for now. I don’t sync inventory, but found that a couple of products said they had synced. I was trying to figure out how to remove the sync when I discovered the missing settings. I am in the process f building my site to open it up, Square isn’t making a good first impression.

    hurtdidit

    (@hurtdidit)

    Similar issue here. I went ahead and made a purchase for $0.15 to test that payments with Square is still working. Everything on the front end, back end, and email traffic looks great.

    But then I went to Square and found that for some reason, I was charged $120!! Instead of purchasing a $15 item and getting 99% off (using a test coupon code), I was charged for the most expensive item in my store. What the heck?!

    I’ve disabled my store altogether until this gets sorted out. I’d rather force customers to call in their orders than to have to deal with refunding every order because of overpayments.

    Plugin Support Mike W

    (@nixiack8)

    Hi All,

    We have had several success actions with uninstalling and re-installing Square.

    – Go to WooCommerce > Plugins and verify you have 2.0.1 or 2.0.
    – If you do, disable the plugin, then delete it
    -Make sure you are installing version 1.0.38 from here. Activate it after installing.
    – After this, you will find the settings under WooCommerce > Settings > Integration > Square

    You may see yourself still connected. If you do, disconnect then reconnect, making sure the Business Location is showing. Do a sync if you have products (WC > Square or vice versa, does not matter, just manual sync matters). If you do not have products you can skip the sync, the payment gateway at that time should work.

    If it does not, please show logs of the errors under WooCommerce > Status > Logs if it is having issues processing payments.

    If it is not syncing correctly, check the fatal logs to see if there are ay sync errors there. If there are, please post them here 🙂

    Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    This is resolved as of version 2.0.3, please update if you’re seeing this with WooCommerce 3.7+.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.