Gravity Forms Salesforce Add-on
[resolved] Settings Page comes up blank (9 posts)

  1. taropaa
    Posted 3 years ago #

  2. Zack Katz
    Plugin Author

    Posted 3 years ago #

    This was fixed in the latest release. Please refrain in the future from creating duplicate posts :-)

  3. heavymark
    Posted 3 years ago #

    Unfortunately this was not resolved. *Noted in the other post as well.

    When enabling error reporting it shows:

    Fatal error: Class 'SoapClient' not found in /var/www/vhosts/ma-smartgrowth.org/httpdocs/wp-content/plugins/gravity-forms-salesforce/developerforce/include/SforcePartnerClient.php on line 44

    According to Google it seems that that means on the server we have to enable "Soap Client" in Apache. This was not noted to my knowledge anywhere on your plugin requirements.

  4. fabioricotta
    Posted 3 years ago #

    I'm expecting the same problem here.

    Are there any tips to solve it?

  5. heavymark
    Posted 3 years ago #

    Yes, you have to compile php on your server with Soap extension. Several people on the form have noted the blank setting issue but he continues to assert that the issue is fixed when it's not. Until he does, if you have root access to your server I followed these instructions and now the extension works:


  6. fabioricotta
    Posted 3 years ago #

    Seems that I'll need to upgrade my PHP in order to have this SOAP module enabled.

    Anyone have another suggestion?

  7. heavymark
    Posted 3 years ago #

    The plugin currently uses "SoapClient" so will have to have that enabled on your server.

    The other option would be that the plugin is recoded to not rely on SoapClient. The developer may eventually do that if enough people request but doubtful. Or switch to a host that supports it.

    What version of PHP are you using? As long as it's relatively new it should be fine. The link I sent was instructions for 5.3.5 but if your using an older version you'd simply have to google enable soap on php (insert your version here). Or google how to enable/install a module on your particular version of php.

  8. Eric
    Posted 3 years ago #

    I am having the same issues where when I click Forms->Salesforce the entire screen is blank. I don't know of any error logs to pull from so I can't post those but I can assume it is the same thing as you posted heavymark.

    I tried looking into phpinfo(); but I wasn't sure what I was looking for so I tried this but it echoed false.

    if (extension_loaded('soap')) {
      echo "soapy";
      echo "not soapy";

    Is there any way around installing soap since that seems like such a process?

    Using PHP 5.3.5

  9. rezon8dev
    Posted 3 years ago #

    @Eric any luck under php5.3?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Gravity Forms Salesforce Add-on
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic