Membership 2
[resolved] [closed] Settings of Download / Media Options Not Masking Files Properly (2 posts)

  1. joshjosh
    Posted 3 years ago #

    I am trying to get a link to a PDF file I have uploaded to the WordPress media library to NOT show its true location on the server, when a subscriber hovers over it, clicks on it, or tries to copy it, within a post.

    But, the options under "Download / Media Options" no matter what I set them to, are not properly masking the URL.

    What am I doing wrong?

    Here are some screen shots so that you can see what my issue is for certain:

    This is what the post looks like on my website. I am logged-in as merely a subscriber, and when I hover over the link to download, it is clearly showing the entire pathway for the document, and where it is hosted on the server. So, it is clearly unmasked:

    Website Post With PDF file download I'm trying to mask:

    Here's what the settings look like for the post when creating it:

    Here are the specific settings in the media library for the PDF file itself, which I am trying to protect:

    These are my permalink settings:

    WordPress media settings:

    Every screen and section of the Membership Plugin Settings:

    Will you kindly take a look at what I've got here, and let me know what can be done? When logged in a simple subscriber, with no admin function, I view this page and the actual link is not masked, but is rather exposed.

    I'm trying to figure out how to get the masking to work.

    If you need any other info from me, please do not hesitate to ask.

    Thanks so much in advance for your input!



  2. ellbristow
    WPMU DEV Support Staff
    Posted 3 years ago #

    This is a duplicate thread.


    Please close this thread and stick to one location. Thanks

    [ Moderator note: closing duplicate topic. ]

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Membership 2
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic