Support » Plugin: Fast Velocity Minify » Settings not saving upon saving advanced settings (and the other way around)

  • Resolved Jpascha

    (@jpascha)


    Hey there,

    I’m having trouble setting the correct settings. Whenever I change a setting and save it in either ‘Settings’ or ‘Advanced’ the settings from the previous tab resets back to default.

    Is this issue known, or am I the only one having this problem?

    Cheers,
    Jan

    • This topic was modified 2 years, 1 month ago by  Jpascha.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Raul Peixoto

    (@alignak)

    This issue occurred a few versions back, but it has been fixed and several people confirmed that it’s fixed on their end. Are you using the latest 1.4.9 version?

    What browser and operating system are you using?
    Does it also happen if you use another browser on some other device (let’s say, mobile for example)?

    Can you also paste a screenshot of the Server Settings Tab here so I can have an idea of the server infrastructure?

    Thanks

    Hello Raul

    I confirm this regression on the version 1.4.9. All worked fine on 1.4.8.
    some of the settings in – settings menu and advanced menu – for example

      Disable minification on CSS files
      Inline all enqueued CSS
      Skip deferring the jQuery library
      Skip deferring completely on the login page

    are not getting saved.

    regards,
    B

    same behaviour on both – safari Mac (Version 10.1.1 (12603.2.4))
    and firefox Mac (53.0.2 64-bit)

    regards,
    B

    I am definitely using 1.4.9, I was using Google Chrome stable on Windows 10 (pre anniversary update) on my work PC, but I’m also having issues on my home PC using Google Chrome beta 58 on Windows 10 Creators Update. I’ve also tested Firefox 53. which had the same issue.

    Here’s the server info:
    http://i.imgur.com/OSlRpR9.png

    From my experience it often happens with options that can be disabled by other options (‘Inline all enqueued css’ for instance) while others do remain checked (like ‘Disable CSS processing’)

    Same experience here for as well on 1.4.9. Using latest Chrome on macOS. Disable merge settings or disable minification won’t save.

    Plugin Author Raul Peixoto

    (@alignak)

    ok guys, I think I know where to look now.

    The idea here was to disable certain options when we disable an option that takes precedence… for example, disabling css processing should disable all it’s children options… but something is not quite right with the logic. I’ll do some more testing and expect to sort all issues on the 1.5.0 version shortly.

    Sorry for the trouble, I was rushing to fix previous issues and while adding some more features I forgot to test it properly.

    No Problem.
    Thanks for your hard work for this plugin
    B

    Plugin Author Raul Peixoto

    (@alignak)

    OK, so the settings were being saved, just not visible (it was a jquery error).
    All sorted out now and tested.

    If you disable CSS or JS processings, their children features will be unselected… that’s the expected behavior.

    Thanks for reporting.

    Cheers man, works like a charm again. Got the website up to 99/100 now 😉

    The plugin has been working great on the many websites I’ve had to use it on, can’t thank you enough for creating it and for the fast support!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Settings not saving upon saving advanced settings (and the other way around)’ is closed to new replies.