• Resolved quitoxic

    (@quitoxic)


    Hi there,
    Is my first time using this plugin and looks great but so far I haven’t managed to save the settings. Anything I change on the settings just go back to what it was. I have disabled my WP Rocket just in case could be an issue but stays the same. any ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author WP User Manager

    (@wpusermanager)

    I’ve seen this a couple of times where the site (usually htaccess) file is forcing a trailing slash to the site URL breaking REST API endpoints (which the plugin uses to save settings).

    I’m investigating a long term fix, but the short term hack is to temporarily remove that setting (maybe in WP Rocket), save WP User Manager settings and turn back on.

    I’m seeing a similar problem.

    From what I can tell, no slash is being appended to the request. When I watch the network events I can see e.g., a call to /wp-admin/admin-ajax.php?action=wpum_update_fields_order and that call comes back with a 200 status. On the screen I can see that the field I dragged is in the correct order. But when I refresh the page, the field jumps back up to the top of the form. Like the re-sequencing didn’t actually save to the API.

    Any ideas?

    Note that some settings are indeed saving. Like I can make fields required and stuff like that. But other settings like dragging and dropping sequence of fields in the form are not saving.

    Plugin Author WP User Manager

    (@wpusermanager)

    Can you edit your wp-config.php file to replace this line –

    define( ‘WP_DEBUG’, false );

    With these lines –

    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, false);

    This means that any errors are logged to `/wp-content/debug.log’, because some errors are not visible on screen.

    More details about that at http://codex.wordpress.org/Editing_wp-config.php#Debug

    Can you then retry the process and send me the debug.log file that should be created.

    The site in question is hosted on wordpress.com so I don’t think I can edit wp-config.php??

    Note that this is paid account so if you prefer we can switch to email for this diagnosis … let me know.

    Plugin Author WP User Manager

    (@wpusermanager)

    Ah that might be part of the issue.

    Yep please send me a message via https://wpusermanager.com/contact/ 👍

    Plugin Author WP User Manager

    (@wpusermanager)

    hey @quitoxic I’ve just released WP User Manager v2.3.10 with this fixed.

    ​Let me know how it goes.

    I just tested v2.3.10 and what’s interesting is that changes I made earlier are now appearing. I’m wondering if something’s getting cached maybe.

    But changes I’m making now don’t appear to be taking effect. They’ll probably show up later, I’m guessing.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.