WordPress.org

Support

Support » Plugins and Hacks » Twitter posts to Blog » [Resolved] Settings not saving

[Resolved] Settings not saving

  • just set up the plugin and created a new twitter app (i think), however after i enter all settings into the plugin admin and hit “save settings”, i dont get an error but when the page refreshes after saving – all the settings go back and the twitter app settings go back to blank.

    what am i doing wrong? im really hoping to get this working to use your plugin as its exactly what i need for our site.

    thank you for your time and any help you can offer 🙂

    http://wordpress.org/extend/plugins/twitter-posts-to-blog/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author badbreze

    @badbreze

    have any error log?

    im sorry…but how can i create an error log for it?

    esmi

    @esmi

    Forum Moderator

    Your hosts should be able to help you in accessing your site’s error logs.

    hope this is it:

    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Non-static method Jetpack_Subscriptions::init() should not be called statically in /usr/local/webapps/wordpress/wp-content/plugins/jetpack/modules/subscriptions.php on line 512, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Non-static method Jetpack_Notifications::init() should not be called statically in /usr/local/webapps/wordpress/wp-content/plugins/jetpack/modules/notes.php on line 181, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  call_user_func_array() expects parameter 1 to be a valid callback, non-static method Jetpack_Post_By_Email::init() should not be called statically in /usr/local/webapps/wordpress/wp-includes/plugin.php on line 406, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Only variables should be passed by reference in /usr/local/webapps/wordpress/wp-includes/pomo/mo.php on line 210, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Declaration of Bulk_Plugin_Upgrader_Skin::before() should be compatible with WP_Upgrader_Skin::before() in /usr/local/webapps/wordpress/wp-admin/includes/class-wp-upgrader.php on line 1359, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Declaration of Bulk_Plugin_Upgrader_Skin::after() should be compatible with WP_Upgrader_Skin::after() in /usr/local/webapps/wordpress/wp-admin/includes/class-wp-upgrader.php on line 1359, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Declaration of Bulk_Theme_Upgrader_Skin::before() should be compatible with WP_Upgrader_Skin::before() in /usr/local/webapps/wordpress/wp-admin/includes/class-wp-upgrader.php on line 1394, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Declaration of Bulk_Theme_Upgrader_Skin::after() should be compatible with WP_Upgrader_Skin::after() in /usr/local/webapps/wordpress/wp-admin/includes/class-wp-upgrader.php on line 1394, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Declaration of TGM_Bulk_Installer_Skin::before() should be compatible with WP_Upgrader_Skin::before() in /usr/local/webapps/wordpress/wp-content/themes/u-design/lib/plugin-activation/class-tgm-plugin-activation.php on line 1893, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Declaration of TGM_Bulk_Installer_Skin::after() should be compatible with WP_Upgrader_Skin::after() in /usr/local/webapps/wordpress/wp-content/themes/u-design/lib/plugin-activation/class-tgm-plugin-activation.php on line 1893, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Only variables should be assigned by reference in /usr/local/webapps/wordpress/wp-content/plugins/wpml-string-translation/inc/auto-download-locales.php on line 24, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Non-static method Jetpack_User_Agent_Info::is_ipad() should not be called statically in /usr/local/webapps/wordpress/wp-content/plugins/jetpack/modules/custom-css/custom-css.php on line 17, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] The DG Twitter to blog plugin require CURL libraries, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: privileges in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 33, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: privileges in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 34, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: privileges in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 35, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 46, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 47, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 48, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 49, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 50, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 51, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 52, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 53, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 54, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 55, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: run in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 56, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: method in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 121, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: method in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 122, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: author in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 132, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: ui in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 178, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: text in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 188, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: img_size in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 200, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: img_size in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 201, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: img_size in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 202, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: img_size in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 203, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: ipp in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 213, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: title_format in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 222, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: maxtitle in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 225, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Notice:  Undefined index: badwords in /usr/local/webapps/wordpress/wp-content/plugins/twitter-posts-to-blog/admin_page.php on line 234, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [debug] mod_deflate.c(602): [client 192.168.3.1] Zlib: Compressed 56120 to 10741 : URL /wp-admin/admin.php, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Non-static method Jetpack_Subscriptions::init() should not be called statically in /usr/local/webapps/wordpress/wp-content/plugins/jetpack/modules/subscriptions.php on line 512, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Non-static method Jetpack_Notifications::init() should not be called statically in /usr/local/webapps/wordpress/wp-content/plugins/jetpack/modules/notes.php on line 181, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  call_user_func_array() expects parameter 1 to be a valid callback, non-static method Jetpack_Post_By_Email::init() should not be called statically in /usr/local/webapps/wordpress/wp-includes/plugin.php on line 406, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Only variables should be passed by reference in /usr/local/webapps/wordpress/wp-includes/pomo/mo.php on line 210, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Only variables should be assigned by reference in /usr/local/webapps/wordpress/wp-content/plugins/wpml-string-translation/inc/auto-download-locales.php on line 24, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards:  Non-static method Jetpack_User_Agent_Info::is_ipad() should not be called statically in /usr/local/webapps/wordpress/wp-content/plugins/jetpack/modules/custom-css/custom-css.php on line 17, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu

    [Please post log files between backticks or use the code button.]

    Plugin Author badbreze

    @badbreze

    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] The DG Twitter to blog plugin require CURL libraries, referer: http://docs.mobiwork.com/mobiblog/wp-admin/admin.php?page=dg_tw_admin_menu

    You cant use this plugin if you dont have curl on your server, try contacting your hoster for more info.

    thanks for your help! ill try that next. we are self hosting. was that the only error that you could see from the log?

    Plugin Author badbreze

    @badbreze

    i fixed all other errors but i dont understand why you are not able to save settings from backend, try disable and re-enable the plugin

    Hello, don’t mean to bump @mobiwork did you managed to fix this issue?
    [Tue Jun 25 09:35:25 2013] [error] [client 192.168.3.1] PHP Strict Standards: Only variables should be assigned by reference in /usr/local/webapps/wordpress/wp-content/plugins/wpml-string-translation/inc/auto-download-locales.php on line 2
    I’ve been searching on the wpml forum but no luck yet.
    Thank you

    @lemonthirst – actually i wasnt able to get it working but that didnt have anything to do with the plugin. i determined our issue was down to lacking a couple required features in our hosting setup (namely curl) since we are self hosting.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Settings not saving’ is closed to new replies.
Skip to toolbar