Support » Fixing WordPress » Settings menu has disappeared

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator t-p

    (@t-p)

    Have you tried (note this post is not a fix-all, just some possibilities.):

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    -If the above step does not resolve the issue, Download WordPress again and replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies. This should replace your core files without changing your content and settings in wp-config.php file and the /wp-content/ directory.

    Note that some uploaders may not overwrite files reliably, so delete the original files before replacing them.

    -if that does not resolve the issue, try increasing memory available for php.

    Ok, thanks for the suggestions. I tried all that, but still no Settings.

    I replaced everything step by step, until I eventually had the original installation again. What I didn’t expect was that posts and pages are all still there. Where are they stored? (I cleared my browser cache in case it was loading from a local copy.)

    I have the memory limit set to 128MB, and everything together came to 30MB when I made my backup, so I wouldn’t expect memory to be a problem.

    In this forum there was something similar caused by whitespace. Does anybody know where I should start looking for whitespace which would make the Settings menu disappear?

    Where are they stored?

    In your database.

    Try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

    Hmmm, still no Settings menu.

    What should this line do? Is there anything else I can check to see if it changed anything at all?

    Could there be anything in my database which would alter the wordpress admin area?

    Moderator t-p

    (@t-p)

    griffinslehre

    (@griffinslehre)

    I’m still having the same problem. Since resetting all the FTP files didn’t change anything, I think the problem must be in the database.

    My current idea is: the settings menu would be invisible for non-Administrators, right? It says I am logged in as an administrator, but would it be possible for someone to break into the database and reduce the rights of administrators? (Or for me to have done this by accident?)

    If this theory is right, how would I reset this in the database?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Settings menu has disappeared’ is closed to new replies.