WordPress.org

Support

Support » How-To and Troubleshooting » Settings > Reading > Front Page Displays > Posts Page

Settings > Reading > Front Page Displays > Posts Page

  • I’m using 2.7, which wasn’t an option in the version field above, fyi.

    I’ve set my install to show a static front page, which is working. I created another page, just called blog, and set this as my posts page. The page is published, and the slug is simply blog. But if I code a nav item in my header to link to blog (or /blog or /blog/) it doesn’t exist. I can hard code the page id and it works fine.

    Why won’t the slug work? I used this method in 2.5, pulling /blog/ from the permalink, and it worked fine.

    Thanks for assistsance.

Viewing 2 replies - 1 through 2 (of 2 total)
  • I am having the same problem.

    This is a new install of WP 2.7.1. I created a homepage “page” and a specific template for it. I then created a blog “page” and set that as the posts page. Now when I go to /blog I just get “Sorry, no posts matched your criteria.”.

    Please help. This seems to be asked a lot on these forums and no one has answered. The Codex just gives this same instruction so please don’t link to that.

    Nevermind I had been using something that was looking for a specific category in my template.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Settings > Reading > Front Page Displays > Posts Page’ is closed to new replies.
Skip to toolbar