Support » Fixing WordPress » Settings > General > Language “blocked” to English…

  • Hi everyone,

    First post on the forum – I think am in the right place but sorry if not…

    My issue is quite simple but triggers plenty of small bugs that drive me mad especially as I have spent a lot of time and trials to fix it unsuccessfully.

    My website (eatcetera.co) is a French e-commerce executed through woocommerce plugin.
    I have a several other plugins installed – everything is up to date.

    For some obscur reason, I am totally unable to set my site language to FRENCH in the WP dashboard (settings > general > site language). It remains blocked (set) to “English” even when I click-save to change it from the drop-down menu. Weridly (or maybe not?), my WP dashboard is showing up half-French half-English.

    I wouldn’t mind so much if I wasn’t under the impression that this forces my woocommerce pages/tables/etc to display in English, creating a bad experience for my French consumers…

    I have tried to set up WP to French using different methods (upload .PO/.MO files in my ftp, setting WPLANG to fr_FR in my config.php file, etc), none of it is working.

    I have also tried to investigate with woocommerce support/forums, no one was able to help me in a way that solves this pb… At the moment I am doing manual translations of the woocommerce templates but there are terms I don’t even manage to locate within the woocommerce files (such as the order-details table for example, that continues to display “Shipping” instead of “Livraison”; or certain woocommerce info-messages that pop up upon a given action, etc)…

    As you can tell by now, I am far from being skilled when it comes to coding, and am sure I have done many things wrong, but I would really apreciate if someone could have a look into my issue and help me solve it!

    Many many thanks 🙂
    Stephane

  • You must be logged in to reply to this topic.