Support » Plugin: WC Fields Factory » Settings don’t save, unable to add fields to products

  • I tried this plugin, and it does not work as described, at my end. Adding fields do not save when clicking publish or update.
    The documentation was not useful in my case.
    I suspect this is a potentially good plugin, but (in my opinion) is challenging with regards to documentation, ease of use (it was not), and intuitive UI.
    Sadly, I uninstalled the plugin 🙁
    Possibly in a few more versions some of these challenges will be overcome.

    Update…

    After investigation (all plugin deactivation, singular reactivation, etc.) It was discovered there seemed to be a conflict (probably javascript based). After reactivating all, this plugin works nicely.

    One suggestion though…

    As most surfing, etc. is done via mobile (and Google is using the “Mobile First” initiative), we found the plugin is not mobile friendly, as it’s still using old style <td><tr> tags.

    We found the input were visible in desktop versions, but on mobile phones (for example) the input fields were not very visible (so small that the placeholder text was not visible).

    To get some kind of fix, we suppressed the labels (as that information can be displayed in the placeholder). We used this CSS as a bandage fix:

    table.wccpf_fields_table td.wccpf_label, table.wccpf_fields_table td.wccpf_label label {display: none !important;}

    The above CSS improved the visibility when using a mobile phone.

    Any chance this plugin at some point will become mobile friendly (using responsive design)? Using <div> tags instead of tables / row tags?

    Thanks again! Appreciate the plugin, nice job!

    • This topic was modified 3 years, 3 months ago by NOT-IN-USE-DELETE. Reason: Added findings and updated information
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author sarkparanjothi

    (@sarkparanjothi)

    Hi,
    Sorry for that. Can you please tell your wordpress, php, Woocommerce Version
    And also share u are using theme name

    Hi,

    I have the same problem.

    Woocommerce version: 3.4.5
    PHP version: 7.2

    I’ve tried with many themes.

    Can you help, please?

    Thanks.

    • This reply was modified 3 years, 4 months ago by joseveiga.
    Plugin Author sarkparanjothi

    (@sarkparanjothi)

    If you in wcff field config editor check your browser console have any javascript exception is there.

    Because all fields meta saving from ajax (using JavaScript). while clicking publish button or before any error happen in javascript meta will not save.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Settings don’t save, unable to add fields to products’ is closed to new replies.