Support » Plugin: Nextend Social Login and Register » Settings cannot be saved!

  • Resolved daro2013

    (@daro2013)


    Hi Developer,

    I have tried your Nextend Social Login plugin on my wordpress website, it does not allow me to save the settings for Facebook login after I entered App ID and App Secret. Here is the message generated when pressing Save button in Nextend settings:

    By replacing your existing Facebook App, users with linked Facebook accounts will no longer be able to login with Facebook.

    I have read the guide on your website, and use this short code on a registration page of my website:

    [nextend_social_login login=”1″ link=”1″ unlink=”1″ heading=”Connect Social Accounts”]

    so that users can link/unlink their facebook account with my website. But it does not show anything on front page except the same shortcode.

    Any advice is very appreciated.

    Cheers

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Support Laszlo

    (@laszloszalvak)

    Hi @daro2013

    Don’t worry this is only a warning that we display, when you have any Facebook App ID saved in Nextend Social Login. Since if you have an existing App and you replace it, then users with linked Facebook accounts won’t be able to login with the new App. ( This is not really a Nextend Social Login limitation, but a Facebook limitation as each App returns a different users ID for the same user. )

    Returning to your problem:
    What you need to know, is that our shortcode will only turn into social buttons if you have at least one provider that was verified and enabled.

    Once you saved the Facebook App ID and App secret in Nextend Social Login, did you verify the settings? Also did you enable the provider? If you go to our Dashboard there you can see the status of each provider. For the enabled providers you should see a green “Enabled” label.

    As for the shortcode:
    If I check the shortcode that you pasted here, then the opening and closing quotation marks seem to be different. Please make sure there are the same.

    Note: websites might encode the quotation marks for security purposes and that’s why you may end up with different characters, but if you copy the shortcode from our Usage tab in the plugin those should work fine.

    Important note:
    By default our shortcode will only display the social buttons for the users who are not logged in yet.
    But if you use the link and unlink parameters like it appears in your message above ( just with the proper quotation marks ) then the link unlink buttons will be displayed for the logged in users.

    Best regards,
    Laszlo.

    Thread Starter daro2013

    (@daro2013)

    Thank you for very prompt support.

    I have not seen a Green button under Provider setting of the plugin. I only see get started (for the one not being set yet) and Verify Settings (for the one I have set which is Facebook social login).

    Where can I enable the provider?

    Cheers

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @daro2013

    If you have enabled providers then you can check that in the providers list. See:
    https://imgur.com/a/ivhPa9R
    this is what I meant by the green “Enabled” label.
    But if you rather see the “Verify Settings” button, that means your provider is not enabled yet, as you need to verify it first.

    Could you press that “Verify Settings” button please? See: https://imgur.com/a/becxlam
    Once you verified the provider settings, an enable Button will appear on the Settings page of the Facebook provider that you can use to enable the provider.

    If Facebook gives an error during the verification, could you tell me the error message you received?

    Thread Starter daro2013

    (@daro2013)

    More info: I did try to verify, but the plugin just opened a new windows of browser and show the same page I was on which is Settings of the plugin.

    It seems I cannot find where to enable the provider (facebook)?

    Any advice is very appreciated.

    Thanks

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @daro2013

    If you see your own site being opening in the popup that usually means the /wp-login.php page on your site is not accessible, and since we are trying to handle our codes over that page we won’t be able to do that either.

    To fix this problem you should make Nextend Social Login handle its codes over a page other than the wp-login.php. `For that you should use our “OAuth redirect uri proxy page” setting and the “Page for register flow” setting, what you can find on our General tab:
    https://nextendweb.com/nextend-social-login-docs/global-settings

    You should configure them this way:
    For the Page for register flow: You should create a new page and place the shortcode into it: [nextend_social_login_register_flow] then select that page for this setting. Extra information before the registration with social login – like Terms and Conditions – would be asked on this page. ( Make sure you don’t use this page for anything else! )
    For the OAuth redirect uri proxy page: You should create another new and completely empty page ( that you won’t use for anything else either ) and select it as OAuth redirect uri proxy page. Once it is done, the redirect URL of each configured provider will change, as the OAuth flow will be handled over this new page instead of the /wp-login.php page. Then you will need to add the new redirect URLs into each of your configured Apps again. ( Nextend Social Login will also warn you about this with a message, where you can see all the steps, but actually, you can find the redirect URLs in the Getting Started section of the providers, too. – The redirect URLs are the URLs that usually contain this query string: “?loginSocial=” )

    Let me know if you still see problems even after making these changes!

    • This reply was modified 2 months, 2 weeks ago by Laszlo.
    Thread Starter daro2013

    (@daro2013)

    thanks again for quick help.

    I can confirm that my facebook account login is verified as I have used it with Super Socializer social login without issue.

    Does your plugin require extra settings in facebook settings at facebook.com?

    Cheers

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @daro2013

    Different social login plugins have different endpoints that they use, so yes you need additional configurations.
    If you have already created an App earlier, then please check the steps on the Getting Started tab of our Facebook provider and make sure you add all of those details to your Facebook App.

    However please make sure you configured the “Page for register flow” and “OAuth redirect uri proxy page” settings as I suggested above.

    Thread Starter daro2013

    (@daro2013)

    Thanks. I could know what the issue is. I use Hide My WordPress plugin to change WP login page (wp-login.php), to something like:

    https://www.mydomain.com/myadmin-login/

    instead of:

    https://www.mydomain.com/wp-logiin.php

    How can I fix that?

    Cheers

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @daro2013

    Using the “Page for register flow” and “OAuth redirect uri proxy page” settings as I suggested above, will fix the problem in this case!

    Thread Starter daro2013

    (@daro2013)

    -The facebook is enabled now after I did what you suggested in Global settings:

    Page for register flow: Register (I create a Register page; not use wp default page)

    OAuth redirect uri proxy page: Login (I create a Login page; not use wp default login page)

    -Then change Oauth URI in facebook settings suggested by your plugin

    -Come back to Verify settings, it is verified and Facebook provider is enable.

    -Place a short code in Login page.

    -However, I cannot access Login page at front end which is:

    https://www.mydomain.com/login/

    It will redirect to home page.

    How can I fix it?

    Cheers

    Thread Starter daro2013

    (@daro2013)

    Update: both register and login pages cannot be accessed; they are redirected to Homepage.

    I only put short code in Login page; not in Register page.

    How can I fix this?

    Thanks

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @daro2013

    Is it possible that you selected your login and register pages for our “OAuth redirect uri proxy page” and “Page for register flow” settings?
    If you did, then that will be the problem. As I mentioned above, you need to create new pages for these settings that you don’t use for anything else, as we will reserve the selected pages.
    ( So you need to create 2 new pages in total, one for the “OAuth redirect uri proxy page” setting and another for the “Page for register flow” setting. )

    Thread Starter daro2013

    (@daro2013)

    It seems working on Register page after I set:

    Page for register flow: None
    OAuth redirect uri proxy page: Login

    In that case, Login page is not accessible; it redirects to homepage?

    Can I set any page in:

    OAuth redirect uri proxy page

    (not neccessary Login or Register pages)

    I would like to place short code of Nextend on both pages which are Register and Login.

    Can you please advise how to do that.

    Cheers

    Thread Starter daro2013

    (@daro2013)

    It is just blank pages? I understand, I am going to create a new pages for that, and let you know how it goes.

    Cheers

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @daro2013

    For our “Page for register flow” setting:

    • you need to create a new page
    • then add this shortcode to it: [nextend_social_login_register_flow]
    • save the page
    • select the created page as “Page for register flow”

    For our “OAuth redirect uri proxy page” setting:

    • you need to create another new and completely blank page
    • then select this page as “OAuth redirect uri proxy page”
    • this will change the redirect uri of the providers. So you will need to add the new redirect uri for each of your Apps. A warning will appear where you will see the new redirect url of your providers. ( But as I mentioned above in the Getting Started section you will also find the new redirect urls. )
Viewing 15 replies - 1 through 15 (of 28 total)
  • You must be logged in to reply to this topic.