Support » Plugin: Widgets on Pages » “Settings” button in all of the plugins

  • Resolved catmaniax

    (@catmaniax)


    Hello.

    I just updated to the lastest version and I’ve seen the a new “Settings” button appeared first in order in all of my plugins in the wordpress plugins page (/wp-admin/plugins.php)

    Pressing that button goes to the Widgets on Pages settings (/wp-admin/options-general.php?page=widgets-on-pages).

    Can you please fix this and remove this button?

    Also, about the new Tubro sidebars… What’s the use for them? Is it so that the widgets do not go to the Inactive Widgets area if I change themes back and forth? (like what I asked in my older thread? – https://wordpress.org/support/topic/inactive-widgets-when-changing-theme/ )

    Please let me know.
    Thanks!

    • This topic was modified 2 years, 5 months ago by  catmaniax.
    • This topic was modified 2 years, 5 months ago by  catmaniax.
Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Hi there, thanks for the post, and sorry to hear about the buttons. I’m not sure I fully understand, are you able to post a screenshot please?

    Ref the turbo sidebars, yes, that is one of the plans. Also to allow further config, such as layout, when to show, etc.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Ooh would you mind letting me know the name of one of the other plugins that this button affects? This will help me reproduce and fix.

    Here’s a screenshot:

    https://s24.postimg.org/4spy01nol/Capture.jpg

    The button appears all of the plugins, not just some.

    The Turbo sidebars sound interesting. How can they be further edited and change layouts and when to show?

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Oh I see… crikey, sorry.

    At the moment they don’t have that capability, but the move to using CPT (Custom Post Types) now gives me the structure to add all this in, and more.

    Thanks for the info, this will def help me get a fix out.

    That’s great, I will be waiting for the new version 🙂

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    I do hope so 🙂

    I have a fix now for this… but am going to run through the full set of tests again (plus the extra ones I’ve added following the move from v0.0.12)

    Again, I really appreciate you raising this issue, it’s only through folk like you making an effort, and understanding, that plugins really evolve.

    Thanks, I’m trying my best to always point out things that help make the plugins better and take them a step forward.
    Unfortunately, the sad part is that most plugin authors, unlike you, don’t really listen/care.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Hi @catmaniax, I have an update that fixes your issue (and can share a download link if you’re happy to update manually).
    I have not released this to the main repo yet as I’m still trying to iron out upgrade issues seen for users still on v0.0.12 and below.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    A ha!
    I have sussed the issue that was seen by others during… phew.
    I will be testing this thoroughly, and hope to have a push to WordPress.org toward the start of next week, all being well.

    Thanks for your patience.

    • This reply was modified 2 years, 5 months ago by  toddhalfpenny.

    That’s good to hear 🙂

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Hey @catmaniax,

    I have released version v1.0.3 that should include a fix for this.
    Could you please let me know how you get on?

    Thanks

    Strange, no updates are showing as available in my WordPress, I’m using version 1.0.2 of your plugin.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    So sorry @catmaniax, I had an upgrade ready and it was looking good for about 2000 users, and then I started seeing reports of issues with some users on earlier versions of PHP.
    I’ve reverted the stable version, but do have a v1.0.3, if you’re interested… Let me know.

    Hopefully I know the problem now, and will have a proper upgrade out in the next day or two.

    Thanks, I’ll just wait then 🙂

    Hey, I just updated and got a 500 error.
    Can you please check?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘“Settings” button in all of the plugins’ is closed to new replies.