Support » Plugin: Helpful » Settings are not taken into consideration

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Pixelbart

    (@pixelbart)

    @timtimseo

    I have tested this all over again on my end. Everything runs without problems. You also did not respond to my questions last time.

    The plugin is used by many people and so far there is no message about your problem.

    Are you using a caching plugin in WordPress, or your server? If so, you need to look there. Also, it’s important that you haven’t overridden things with a filter somehow.

    It’s hard to find the cause if you don’t get any information. You’re referring to your last post, in that you haven’t shared any information with me yet either.

    Please take another look. If you have more information, I’m sure I can help you somehow.

    Plugin Author Pixelbart

    (@pixelbart)

    Before I forget: There are since some versions the following two options for the feedback form:

    • Helpful > Settings > Feedback > Already Voted > Always show the form, even if it has already been voted.
    • Helpful > Settings > Details > General > Disable feedback completely.

    Maybe you have set a checkbox for Already Voted.

    Edit: The Disable feedback completely option does not uncheck Already Voted. This is a bug that I still need to fix, it seems (is fixed with 4.4.26).

    • This reply was modified 4 months, 2 weeks ago by Pixelbart.
    • This reply was modified 4 months, 2 weeks ago by Pixelbart.
    • This reply was modified 4 months, 2 weeks ago by Pixelbart.
    Thread Starter timtimseo

    (@timtimseo)

    Hi @pixelbart

    Thank you for your insight and availability.

    It turns out you were right, I had activated

    Helpful > Settings > Feedback > Already Voted > Always show the form, even if it has already been voted.

    Deactivating this option fixed the issue, now the form only pops-up after negative vote which is expected from the settings and the text is the right one.

    The confusion comes from the fact that when using the option “Always show the form” the displayed text that is shown is :

    “Thank you very much. Please write us your opinion, so that we can improve ourselves” (this text is nowhere to be found in the configuration options)

    Instead of the custom message set in Texts > After Voting (pro & contra)

    Is this behavior voluntary ?

    Either way, thank you very much for your helping out, and in general for your dedicated work on this awesome plugin.

    • This reply was modified 4 months, 2 weeks ago by timtimseo.
    Plugin Author Pixelbart

    (@pixelbart)

    @timtimseo

    The text for Already Voted should also be found under Already Voted. I will have another look at it today or tomorrow.

    Actually, all texts should be controllable via the settings. These are all implemented wishes from other users. That’s why they might not be in that order yet.

    Thread Starter timtimseo

    (@timtimseo)

    @pixelbart

    Yes it is, but left empty on my install, which seems to cause some kind of a fallback text to pop instead.

    Plugin Author Pixelbart

    (@pixelbart)

    @timtimseo

    Sorry for the late response. With the latest version (4.4.27) your problem should be fixed. The feedback text is now no longer automatically filled if none is specified.

    Thank you again for your feedback!

    Stay healthy!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.