WordPress.org

Support

Support » Plugins and Hacks » Setting up WordPress for Android app

Setting up WordPress for Android app

Viewing 15 replies - 1 through 15 (of 15 total)
  • mbrsolution
    Participant

    @mbrsolution

    Hi psheld, you can try the following tutorial.

    Let me know if that helps you.

    Kind regards

    psheld
    Participant

    @psheld

    Thanks mbrsolution, but I have Google Authenticator working just fine for browser login. My challenge is getting the WordPress Android app working too.

    mbrsolution
    Participant

    @mbrsolution

    Okay sorry for the misunderstanding. What have you done so far that is not working for you?

    psheld
    Participant

    @psheld

    Thanks. I’ve gone to Users in WordPress admin, and ticked the box “Enable App Password”. When I type this password into the Android App I’m told:

    “ERROR: The Google Authenticator code is incorrect or has expired.”

    mbrsolution
    Participant

    @mbrsolution

    Have you tried to scan the barcode with your android app? That is what I did with my iPhone app. I placed the camera focusing on the barcode that shows on your account. The app identifies the barcode and adds the account to the app. Then all you have to do is when you try to log into your account the app will reveal a passcode to enter on your login. Remember that passcode will refresh in about 60 seconds or so.

    Try that and let me know if that helps you.

    psheld
    Participant

    @psheld

    Thanks for trying to help here mbrsolutions, but I think we have crossed lines.

    I have Google Authenticator set up perfectly. I can go to /wp-admin, enter my username, password and Authenticator code, and I’m in. That’s not the problem.

    The problem is being able to use the WordPress app for Android.

    mbrsolution
    Participant

    @mbrsolution

    Once again sorry 🙂 I seem to be misunderstanding you. It must be late at night.

    Unfortunately for you I don’t have an android phone to test your issue 🙁

    Sorry about this.

    psheld
    Participant

    @psheld

    I met two people at a conference on Saturday who have the same problem as me, as documented here. We were hoping to find someone else at the conference who’d cracked it, but no-one came foreword. Frustrating.

    jackalope
    Member

    @jackalope

    hello psheld
    did you solve your problem?

    i’ve the same too here…

    regards

    psheld
    Participant

    @psheld

    Unfortunately no. It appears, from what I can determine, that two-factor authentication is incompatible with WordPress smartphone apps.

    I consider the former the more important of the two, so now live without the apps. 🙁

    jackalope
    Member

    @jackalope

    Undestood..
    thanks psheld, uninstalled app and waiting for better time 😀

    regards

    James Huff
    Support Team Rep.

    @macmanx

    Just a quick thought, as I ran into this problem with the iOS too. When the new app-specific password appears, it doesn’t actually save to your profile until you hit “Update Profile” at the bottom.

    I know it’s a bit counter-intuitive, but here’s what I had to:

    1. At Users -> Your Profile in your Dashboard, under “Enable App password,” hit “Create new password.”

    2. Enter this into the password field of the app (or save elsewhere), don’t save it in the app yet!

    3. Hit “Update Profile” at the bottom of your profile.

    4. Now, save the new password in the app.

    jackalope
    Member

    @jackalope

    Hello MacManX
    i just did exactly what you say but still got error 🙁

    Android App

    James Huff
    Support Team Rep.

    @macmanx

    Hm, not sure then. Maybe this is a problem specific to the Android app.

    jackalope
    Member

    @jackalope

    probably….

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Setting up WordPress for Android app’ is closed to new replies.