WordPress.org

Forums

Google Authenticator
Setting up WordPress for Android app (16 posts)

  1. psheld
    Member
    Posted 1 year ago #

    Hi, can someone point me to definitive instructions on how to set up the WordPress Android app with this Google Authenticator plugin.

    I've seen links to the wordpress.com instructions, but they don't translate to self-hosted.

    Thanks in advance.

    https://wordpress.org/plugins/google-authenticator/

  2. mbrsolution
    Member
    Posted 1 year ago #

    Hi psheld, you can try the following tutorial.

    Let me know if that helps you.

    Kind regards

  3. psheld
    Member
    Posted 1 year ago #

    Thanks mbrsolution, but I have Google Authenticator working just fine for browser login. My challenge is getting the WordPress Android app working too.

  4. mbrsolution
    Member
    Posted 1 year ago #

    Okay sorry for the misunderstanding. What have you done so far that is not working for you?

  5. psheld
    Member
    Posted 1 year ago #

    Thanks. I've gone to Users in WordPress admin, and ticked the box "Enable App Password". When I type this password into the Android App I'm told:

    "ERROR: The Google Authenticator code is incorrect or has expired."

  6. mbrsolution
    Member
    Posted 1 year ago #

    Have you tried to scan the barcode with your android app? That is what I did with my iPhone app. I placed the camera focusing on the barcode that shows on your account. The app identifies the barcode and adds the account to the app. Then all you have to do is when you try to log into your account the app will reveal a passcode to enter on your login. Remember that passcode will refresh in about 60 seconds or so.

    Try that and let me know if that helps you.

  7. psheld
    Member
    Posted 1 year ago #

    Thanks for trying to help here mbrsolutions, but I think we have crossed lines.

    I have Google Authenticator set up perfectly. I can go to /wp-admin, enter my username, password and Authenticator code, and I'm in. That's not the problem.

    The problem is being able to use the WordPress app for Android.

  8. mbrsolution
    Member
    Posted 1 year ago #

    Once again sorry :) I seem to be misunderstanding you. It must be late at night.

    Unfortunately for you I don't have an android phone to test your issue :(

    Sorry about this.

  9. psheld
    Member
    Posted 1 year ago #

    I met two people at a conference on Saturday who have the same problem as me, as documented here. We were hoping to find someone else at the conference who'd cracked it, but no-one came foreword. Frustrating.

  10. jackalope
    Member
    Posted 10 months ago #

    hello psheld
    did you solve your problem?

    i've the same too here...

    regards

  11. psheld
    Member
    Posted 10 months ago #

    Unfortunately no. It appears, from what I can determine, that two-factor authentication is incompatible with WordPress smartphone apps.

    I consider the former the more important of the two, so now live without the apps. :-(

  12. jackalope
    Member
    Posted 10 months ago #

    Undestood..
    thanks psheld, uninstalled app and waiting for better time :D

    regards

  13. James Huff
    Volunteer Moderator
    Posted 10 months ago #

    Just a quick thought, as I ran into this problem with the iOS too. When the new app-specific password appears, it doesn't actually save to your profile until you hit "Update Profile" at the bottom.

    I know it's a bit counter-intuitive, but here's what I had to:

    1. At Users -> Your Profile in your Dashboard, under "Enable App password," hit "Create new password."

    2. Enter this into the password field of the app (or save elsewhere), don't save it in the app yet!

    3. Hit "Update Profile" at the bottom of your profile.

    4. Now, save the new password in the app.

  14. jackalope
    Member
    Posted 10 months ago #

    Hello MacManX
    i just did exactly what you say but still got error :(

    Android App

  15. James Huff
    Volunteer Moderator
    Posted 10 months ago #

    Hm, not sure then. Maybe this is a problem specific to the Android app.

  16. jackalope
    Member
    Posted 10 months ago #

    probably....

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Authenticator
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic