Support » Fixing WordPress » Setting up Skippy’s Vhosts

  • Even though this is somewhat of a plugin specific question, I decided to post in the support forums in case anyone like me runs into the same problem.

    The issue: my site is undergoing a restructure, and I’m hoping to have the main blog at and a predetermined category at I have set up both the category and the theme/template with an identical name (“”) and uploaded that theme to the local subdomain, per instructions. You can see it there now as the page is only displaying the generic Apache index. Of course, that’s not really how it’s supposed to work.

    Notes on the versions I’m using:
    MySQL 4.0.22-standard

Viewing 4 replies - 1 through 4 (of 4 total)
  • skippy



    All Apache vhosts should point to the same document root, in which WordPress should be installed.

    The themes for your vhosts should live in /wp-content/themes/ inside the WordPress root.

    It looks like you created a new directory for your wordglot site. Reconfigure using the info above. Let me know if that works.

    Ok, so yes… apparently I’ve had this set up wrong. I created a real subdomain, whereas I should have been using a mod_rewrite rule of some sort. Just emailed my host and they’re going to turn on URL mapping.

    Thanks for the fast response, skippy, you deserved to win that competition 😀




    Thanks Orin.

    I’m open to suggestions on ways to improve the documentation. To me, all domains are “real”: a domain is merely a DNS record, and some Apache configurations telling the server how to service requests for that DNS record.

    I’ve never dealt with hosting providers or the various control panels before, so if they use some standard terminology it might be beneficial for me to use the same.

    Alright. So, I talked with my host. They don’t seem to be much help, as they can’t seem to figure out what I want. From my research what I *believe* I need is a mod_rewrite rule in the .htaccess file of my root public directory. In order for vhosts to function, this rule should direct all requests for a subdomain,, to the WordPress install (following the example: To the visitor, it will appear as a seperate domain, but will be working off the same installation.

    Here’s what I have:
    RewriteEngine on
    Options +FollowSymlinks
    RewriteBase /
    RewriteCond %{HTTP_HOST}*)
    RewriteRule ^$1

    All well and good, except I have no clue what I’m doing so it doesn’t work. Normally, I create a subdomain in my Cpanel and that makes a folder in public_html. I’m renting server space from and they have a shared IP address, which I assume uses httpd.conf to route requests to the various sites on the machine. What I also read was there needs to be an entry _somewhere_, either DNS entry or an http.conf ServerAlias rule, or something, that has * pointing to

    Now the actual question: am I barking up the right tree?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Setting up Skippy’s Vhosts’ is closed to new replies.