WordPress.org

Support

Support » Multisite » Setting up multisite with 'The page isn't redirecting properly' error

Setting up multisite with 'The page isn't redirecting properly' error

  • I did the following steps and so far so good:
    1. install Bitnami WordPress stack
    2. edit Apache2 httpd.conf and make document root point to …/apps/wordpress/htdocs/
    3. set directory in httpd.conf as follow:

    Alias /wordpress/ "/opt/www/apps/wordpress/htdocs/"
    Alias /wordpress "/opt/www/apps/wordpress/htdocs"
    <Directory "/opt/www/apps/wordpress/htdocs/">
        Options Indexes MultiViews +FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
        RewriteEngine On
        RewriteBase /opt/www/apps/wordpress/htdocs/
        RewriteRule ^index\.php$ - [L]
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^/$ /opt/www/apps/wordpress/htdocs/ [PT]
    </Directory>

    4. comment out the Include of “…wordpress.conf”
    5. edit wp-config.php and add the following lines after

    <?php
    define('WP_ALLOW_MULTISITE', true);
    define('WP_HOME','http://mysite.com');
    define('WP_SITEURL','http://mysite.com');

    6. test on mysite.com and everything works fine
    7. upgrade to wordpress 3.3.1 and 6 other default plugins and I can still use mysite.com directly access my site at root
    8. activate network mode
    9. follow the instructions by copying codes to wp-config.php and .htaccess with

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'meetsky.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    and

Viewing 3 replies - 1 through 3 (of 3 total)
  • RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    respectively

    10. Logout and tried to login again
    This is where I get “The page isn’t redirecting properly” error.
    I cannot see the login page until I commented out the newly copied define lines in wp-config.php.

    I am lost and don’t know what went wrong.
    Please help. Thanks in advance.

    typo meetsky.com should be mysite.com in define line

    Just find out that I cannot find or install any theme or plugins from the admin panel. Strange, I had installed one before. Now I get “An Unexpected HTTP Error occurred during the API request.” when I click [Search]

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Setting up multisite with 'The page isn't redirecting properly' error’ is closed to new replies.