Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Setting up authentication for Google Photos

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter dougienisbet

    (@dougienisbet)

    The URL it is trying to go to is: https://accounts.google.com/o/oauth2/auth?access_type=offline&

    I notice though, that hovering over the Step 1: Authenticate button that the target URL that shows at bottom of browser window is much longer and contains client ID and other stuff.

    Thread Starter dougienisbet

    (@dougienisbet)

    Out of curiosity I tried installing another plugin for displaying Google photos in WordPress. It did exactly the same thing.

    Plugin Author Sayontan Sinha

    (@sayontan)

    Is it possible that you have a plugin that is doing this? If your button shows a different link, then that is where you should be going to when you click on it. The only way you wouldn’t get to that link is if there is something modifying that link on the fly. Since you have the same behaviour with another plugin as well, these are indicative of a specific plugin doing these modifications.

    Basically the & shouldn’t be showing up there, and its presence causes me to suspect a plugin.

    Thread Starter dougienisbet

    (@dougienisbet)

    Hmmm … I don’t think so but I’ll have a look. I don’t have that many plugins installed. I shall try de-activating some of them and see what happens.

    Thread Starter dougienisbet

    (@dougienisbet)

    No joy.

    Here’s a screengrab showing the [smudged] URL that appears when hovering over the Auth button.

    photonic_auth

    Plugin Author Sayontan Sinha

    (@sayontan)

    What happens if you right-click and open in a new tab?

    Thread Starter dougienisbet

    (@dougienisbet)

    You can’t. I’d tried that and right-clicking immediately operates as a normal click. Hmmm …. This is in Chrome and Firefox under Linux (Debian XFCE). I’ll try it in Windows and see if it’s the same behavour.

    Thread Starter dougienisbet

    (@dougienisbet)

    Oh well played! While I was booting up Windows (something I don’t do much) I tried it on a Mac running Safari. I can’t recall what extraordinary combination of Apple Key and Trackpad fumbling I did but I managed to get a menu offering to open in new tab or copy link.

    I copied the link and pasted it into a new tab. It was trying to use the URL of the website itself (elvet-striders.uk) as the userid – so I selected login as another user, and then got the authorization screen. Things are now looking quite promising.

    Thanks

    Dougie

    PS: Just found the Flickr Group thread and got that working too. I can’t reply to that thread because it’s closed, but I’d been trying to get this working by entering userid (the asterix made me think it was a mandatory field) – but once I tried the shortcode in your example it was much easier.

    Thanks again for the plugin. I may now have to buy you a THIRD coffee 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Setting up authentication for Google Photos’ is closed to new replies.