Support » Plugin: Boxers and Swipers » Setting to “apply” Boxers and Swipers in pages and posts not working

  • Resolved thomei



    I really like Boxers and Swipers. But we face some really nasty issues. We face the same issues on a few different pages:

    1) The default setting to “apply” isn’t set. It’s disabled. This used to be different a while ago. Default should be enabled.

    2) The “Apply”-setting in posts and pages aren’t stored. It’s completely ignored.

    3) All pages and posts are set to “boxersandswipers_exclude“=”1” now. We didn’t set this value. Many old pages haven’t been edited since years, but they include this “new” added setting too.

    4) If I manually set the “boxersandswipers_exclude“-value to “0” with the “custom fields”-plugin, Boxers and Swipers works as it should. But on next saving of the page/post, the “boxersandswipers_exclude“-value is set to “1” again. Really cumbersome!

    What could cause this issues?
    Any idea, how to fix this issue?
    How to batch set all pages to “boxersandswipers_exclude“=”0” ?
    How to set “boxersandswipers_exclude“=”0” as the default for all post-types?
    How to make the “Apply”-setting in posts and pages working again?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Katsushi Kawamori


    I know the problem. However, I can’t handle it well. It seems to happen when the block editor autosaves.

    If you try the following, you will stop saving “boxersandswipers_exclude” when saving.
    line 51 add_action( ‘save_post’, array( $this, ‘save_exclude_boxersandswipers_postdata’) );

    Comment out line 51.

    Plugin Author Katsushi Kawamori


    Excluded the exclusion settings in version 3.13.

    Thread Starter thomei


    Thank you very much.
    V 3.13 Seams to work smooth now, on all pages.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Setting to “apply” Boxers and Swipers in pages and posts not working’ is closed to new replies.