Support » Plugin: Members - Membership & User Role Editor Plugin » Setting to allow changing author

  • Resolved sarahsas

    (@sarahsas)


    Hello! I’m having trouble with the following, hoping you can point me to the right permission setting…

    Currently when I’m logged in to my site’s dashboard, no matter what user type I’m logged in as, if I want to “quick edit” a post or page to change the author, the only authors that show up as dropdown options from the author list are those that are assigned as ADMINISTRATORS. I have several users who should have EDITOR and AUTHOR permissions, so presumably those users should also show up in this dropdown list, but they don’t…

    I’ve explored all permissions I can think of to get them to show up in the dropdown, but no matter what permissions I change from the MEMBERS user type settings, they will not display in the author dropdown unless I change them to Administrators.

    Can you point me in the right direction, please? What setting do I need to change in the permissions? Help! Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Caseproof

    (@caseproof)

    Hi @sarahsas

    Can you try the code in this snippet and see if that helps: https://gist.github.com/renventura/95ef0efc99c42092aa98180aa7677ef6

    If not, can you check if this is not some sort of plugin/theme conflict? You can do this by deactivating all your plugins temporarily to see if this resolves the problem. If this works, re-activate all plugins one by one to see which one cause that issue.

    Kind regards

    Thread Starter sarahsas

    (@sarahsas)

    Hello, thanks so much for the suggestion. Unfortunately that solution didn’t work for me, because there was no REST API call to fetch the authors on the screen I was having problems with.

    I found a solution though… so for future reference, I was able to get the authors I wanted listed in the drop down, by hooking into this filter:

    add_filter( ‘wp_dropdown_users_args’, ‘change_user_dropdown’, 10, 2 );

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.