Support » Plugin: WP User Manager - User Profile Builder & Membership » Setting the translation

  • Resolved macdilles

    (@macdilles)


    I have “Loco Translate” and it shows that WP UM is completely translated to German. Unfortunately, everything is displayed in English on my website.
    With the other plugins it works, what do I have to set that this also works here?

    I’m still testing WP UM, so far I’m very satisfied and will buy the extensions soon. Just want to make sure that functions like translation also work correctly. 🙂

    Thanks and Regards
    MacDilles

Viewing 7 replies - 1 through 7 (of 7 total)
  • pekos

    (@pekos)

    Hi Alessandro

    same thing happens to me. I read that you created a new text domain for better/full compatibility with wp.org guidelines. However i would like to know if there is a way to migrate. How can I get those translations i did manually with Loco translate to the new file?

    thanx

    Plugin Contributor Alessandro Tesoro

    (@alessandrotesoro)

    @pekos @macdilles

    I’ve just tested loco translate and it seems it could be related to where the files are placed. When you choose to store the language within the loco translate plugin, it doesn’t work.

    If you store the language within the WP’s language folder, it works fine. So when you create a language, you need to choose as location, “system”, see https://www.dropbox.com/s/ui24kb5tc4uclgb/Schermata%202018-07-03%20alle%2011.27.22.png?dl=0

    If you have an existing file, have you tried placing it in that folder?

    macdilles

    (@macdilles)

    Hi @alessandrotesoro,

    Ok it works for me like you said, you have to choose system and always empty the cache completely.

    The following sentence in the registration form
    ” I have read and accept the privacy policy and allow “Website” to collect and store the data I submit through this form.*”
    cannot be translated or found in the PO file, where can I find it?

    Regards,
    Daniel

    Plugin Contributor Alessandro Tesoro

    (@alessandrotesoro)

    Ah sorry about that, seems I didn’t update the language file to contain that string, I’ll fix it in the next update. Meanwhile if you need to change the text immediately, you can use the filter of the plugin like this:

    function wpum_my_privacy_text( $text ) {
    
    		$text = sprintf( __( 'I have read and accept the <a href="%s" target="_blank">privacy policy</a> and allow "%s" to collect and store the data I submit through this form.', 'wp-user-manager' ), get_permalink( get_option( 'wp_page_for_privacy_policy' ) ), get_bloginfo( 'name' ) );
    
    		return $text;
    
    	}
    	add_filter( 'wpum_privacy_text', 'wpum_my_privacy_text' );

    Add this to your theme’s functions.php file. Now you can customize the text within that code. When the next update comes out, remove that code and you’ll be able to translate it as you would normally do.

    macdilles

    (@macdilles)

    All right, thanks and no problem 🙂

    Would you then please add the function that you can show and hide exactly this checkbox and the text for it as you like? Like the checkbox “Enable terms & conditions”.
    That would be great! 🙂

    Thanks and Regards,
    MacDilles

    Having similare problem, renamed the .po and .mo to wp-user-manager-fr_FR.mo / wp-user-manager-fr_FR.po

    Put in both, wp-content/langages/plugins and wp-content/plugins/wp-user-manager/languages

    In loco it say the plugin translation is 100% complete but in front end its like on some part are translated …

    I dont understand, if i explore plugin files, how comme there is 2 textdomain ? wpum and wp-user-manager, is this normal ?? exemple templates > forms > form-account.php use wp-user-manager but account-form.php use wpum

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Setting the translation’ is closed to new replies.