• Resolved lucein

    (@lucein)


    Hello,
    when I navigate to the WMFO tab in the Woocommerce Settings section. The page partially loads and that browser just spins and spins. Never completely loading so I can not edit any of the settings.
    The browser occasionally will give me a popup warning of Waiting for the page to load or to kill the page.
    if I let it run for a long time, it might eventually load. But that is over 15 minutes before the settings page begins to respond again.

    I am running WP 5.9.4
    Woocommerce 6.3.1
    Woo Fraud orders plugin 2.5.6

    please advise

Viewing 8 replies - 1 through 8 (of 8 total)
  • Same here, I even get a HTTP 500 error code. I believe this plugin is abandoned. Too bad, it was great.

    Plugin Author prasidhda

    (@prasidhda)

    Hi, @zelenius @lucein

    Does your sites have too many users? The plugin settings will fetch all the users for one of the settings.
    I suggest you to increase the php memory limit and try again.

    Thanks

    Hi @prasidhda

    My php memory limit is already at 1GB.
    Also, what does it mean “too many users”? How many is too many, for this plugin to work?

    This is definitely not an acceptable answer, there are ways to make this work even if a website has 1M users. Get someone to help you and release a PRO version of the plugin, many people will be willing to pay if this plugin gets fixed.

    Thread Starter lucein

    (@lucein)

    Hi @prasidhda

    My PHP memory limit is 1536MB.

    I do have a large amount of customers. But I am in agreement that increasing the amount of memory is not a good idea or an acceptable answer. that screams of a memory leak in the plugin or design flaw.

    Because if the plugin is loading all 42k customers that I have before the panel loads, that is a design flaw. The panel should only load customers when they are being added. With a search Ajax call so that the number of customers being retrieved and displayed is small and limited to the search.
    that would drastically improve the performance of the panel loading.

    I would be willing to pay for a Pro version. When I saw the problem, that was the first thing I thought of, was to see if there was a pro version. so I could get support and possibly additional features.

    Plugin Author prasidhda

    (@prasidhda)

    Hello @lucein and @zelenius,

    I have made some changes related to above issues in new version 2.6.0. I think this will solve this current issue.

    Thanks for your valuable feedbacks.

    Hi @prasidhda

    Updated to 2.6.0 and this did the trick for me, settings page loads instantly!

    Thank you very much!

    Hi,
    I also updated to 2.6.0 and it works great.

    Great plugin 🙂

    A pro version I would absolutely pay for.

    Thanks for the update.

    Thread Starter lucein

    (@lucein)

    Hello @prasidhda,

    thank you for updating the plugin to fix this. The page now loads without an issue with all the customers that I have.

    Thank you again for the update!

    • This reply was modified 1 year, 6 months ago by lucein.
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Setting Page will not load’ is closed to new replies.