• Resolved kellaman61

    (@kellaman61)


    There is no settings page under the media. When I try access to ‘upload.php?page=warp-imagick’ I get ‘Sorry, you are not allowed to access this page’ error. My account has full admin privileges.

    WordPress Version: 5.7.2
    PHP Version: 7.4.14

    Imagick and GD plugins are active.

    I tried reinstall and install via FTP. Same result.

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author ddur

    (@ddur)

    Hi @kellaman61

    Maybe you have moved it to another position?

    Go to (installed) plugins page, find “Warp iMagick” plugin and click on “Settings”.

    On “General Settings” Tab you will find “Plugin Settings” section and “Select parent menu” field. Set/select parent menu to ‘default’ or wherever you like to find it.

    Thread Starter kellaman61

    (@kellaman61)

    Plugin Author ddur

    (@ddur)

    @kellaman61

    I don’t undestand that language.
    If plugin is activated, first item is “settings”, second one is “deactivate”.
    “Settings” links to your current warp-imagick settings page.

    BTW, that is WP default translation, not from warp-imagick.

    • This reply was modified 6 months, 3 weeks ago by ddur.
    Thread Starter kellaman61

    (@kellaman61)

    Frankly, I don’t quite understand what you mean.
    First item’s (Warp iMagick) first option is not “settings”. It is “deactivate”, and second one is “translate” (for Loco Translate).
    So, Warp iMagick has no “settings”.

    Thread Starter kellaman61

    (@kellaman61)

    In English language:

    https://i.imgur.com/3Xvxz6n.png

    • This reply was modified 6 months, 3 weeks ago by kellaman61.
    Plugin Author ddur

    (@ddur)

    @kellaman61

    I guess, if you deactivate translation plugin, Settings will be back?

    Plugin Author ddur

    (@ddur)

    @kellaman61

    Are you logged in as administrator?

    Thread Starter kellaman61

    (@kellaman61)

    Yes, logged as administrator. There no problems for other plugins.

    Plugin Author ddur

    (@ddur)

    OK, let’s try some other urls:

    /wp-admin/index.php?page=warp-imagick
    /wp-admin/tools.php?page=warp-imagick
    /wp-admin/options-general.php?page=warp-imagick
    /wp-admin/admin.php?page=warp-imagick

    Thread Starter kellaman61

    (@kellaman61)

    I get this error for all: “Sorry, you are not allowed to access this page.”

    Plugin Author ddur

    (@ddur)

    Yeah, that is standard message when settings page is not found or does not exists. For example /wp-admin/index.php?page=xyz will give you same message.

    Do you have some user role plugin installed?

    Plugin Author ddur

    (@ddur)

    Anyways, users had no such issue reported in 1000+ installs, so I believe that you have some plugin conflict.

    Please deactivate/activate other plugins, one by one, until you find conflicting plugin, and please let me know.

    Thread Starter kellaman61

    (@kellaman61)

    Yes, I using https://wordpress.org/plugins/capability-manager-enhanced/

    I tried deactivate this plugin and reinstall Warp iMagick. Same result.

    Plugin Author ddur

    (@ddur)

    I think that you do not have to reinstall Warp iMagick. When conflict is resolved it should just work.

    BTW, Your user role should have capability to ‘manage_options’.

    AND ‘upload_files’

    • This reply was modified 6 months, 3 weeks ago by ddur.
    Thread Starter kellaman61

    (@kellaman61)

    It’s admin account and it’s have all capabilities and Level 10.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Setting Page Missing’ is closed to new replies.