WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Setting minLength and taxonomy types

[Resolved] Setting minLength and taxonomy types

  • Hi,
    Tried to use the plugin, and it’s great, but I’m not able to change the min length trigger, changed it in the admin panel, but it always triggers after 2 characters.

    Looks like in search-autocomplete.js it sets minLength: 2, with no regards to the options.

    The same happens with the taxonomies checkboxes, when either of them is checked it searches in all of the taxonomies, and not filtering only the types that are checked.

    And from looking at searchautocomplete.php, it looks that count( $this->options['autocomplete_taxonomies'] ) > 0 but not checking the returned terms are in this array.

    Would love to get your help and find out what I’m missing over there.

    http://wordpress.org/extend/plugins/search-autocomplete/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Gabe Shackle

    @hereswhatidid

    Thanks for catching this! I’m pushing out an update this evening that will fix this bug.

    Cheers, thanks for fixing for minLength.

    What about the taxonomies options selection? Even when I’m checking only the ‘Categories’ taxonomy in the settings, it will display terms from both the Categories and Tags tables.

    Plugin Author Gabe Shackle

    @hereswhatidid

    Is this the same issue that you posted the separate thread about? If so, could you close this ticket?

    These are two different issues.

    This one is about the type of taxonomies being displayed – even when marking only one taxonomy in the settings, it will display terms from all of the existing taxonomies – no filtering of selected taxonomies occurs.

    The other is about posts not being shown by the autocomplete, when the posts are queried they are put into $resultsTerms, and right after it, $resultsTerms is being used for the terms.
    So on lines 124-129, when merging the two results, $resultsPosts is in fact empty.

    Thanks for your help for looking into this.

    Plugin Author Gabe Shackle

    @hereswhatidid

    I’ve pushed a version this evening that should fix this issue (2.0.6). Please upgrade and let me know if you experience any issues, thanks!

    Looks like it’s working great now, thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Setting minLength and taxonomy types’ is closed to new replies.