Support » Plugin: Quantity Field on Shop Page for WooCommerce » Setting minimum quantity of “1”

  • Resolved strongtyer

    (@strongtyer)


    I can’t figure out how to make sure the minimum quantity is 1 instead of 0. On my category/show/custom pages it’s shwoing 0 and I don’t want my shoppers to have to click the increment button or type in a “1”. Can this be set anywhere else or do I need to add something to functions.php?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author wooassist

    (@wooassist)

    @strongtyer
    you can try adding this to your theme’s functions.php

    function woocommerce_quantity_input_min_callback( $min, $product ) {
    	$min = 1;  
    	return $min;
    }
    add_filter( 'woocommerce_quantity_input_min', 'woocommerce_quantity_input_min_callback', 10, 2 );
    Thread Starter strongtyer

    (@strongtyer)

    That did the trick. Thanks!

    • This reply was modified 6 months, 2 weeks ago by strongtyer.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Setting minimum quantity of “1”’ is closed to new replies.