Support » Theme: Cerauno » Setting line-high

  • Resolved jetsystemservices

    (@jetsystemservices)


    I am experiencing a problem with my pages.

    Inside Page Edit the page looks good, but in the Browsers the lines (<br>) are double space or higher than 1.

    My site page where you can see the problem:
    http://jetsystemservices.com/en/about/

    The segment that is seen like a paragraph is because it does not have <br> lines.

    How can I change the line-high or any other css setting to make the <br> single line or less?

    I already have a Child Theme, what can I enter in the CSS?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    I see a number of formatting issues that are causing problems on the page.

    Line break tags do not require a closing tag.

    Right now you have things like this:

    <br></br><br></br>

    That should instead be:

    <br> – for a single line break
    <br><br> – for a double line break

    You also have an extraneous closing img tag – img tags do not take a closing tag, so you should remove this:

    </img>

    If you view your browser source in Firefox, it’ll highlight all the syntax errors in red, which makes them easy to find.

    Http jetsystemservices com en about

    Once you’ve removed all the </br> and </img> tags that shouldn’t be there, let me know if the line spacing is more to your liking, or if you’d like to tweak anything further.

    On my Page Edit there is only <br> on each line. Somewhere during the rendering of the page those closing tags </br> are (auto)generated.

    <p style="font-size: 18px;"><span style="font-size:18px;"><span style="font-family:times new roman,times,serif;">Jose E. Torres Berrocal<br>M.S. Computer Engineering<br>Phone No. (939) 777-4030<br>jetsystemservices@gmail.com</span></span></p>

    So maybe there is command somewhere in WordPress or the Theme to auto generate the closing tags.

    • This reply was modified 2 years, 7 months ago by jetsystemservices. Reason: Add comment

    I have found this thread:
    https://wordpress.stackexchange.com/questions/1/how-do-i-turn-off-self-closing-tags-for-markup-in-wordpress-for-html5-or-html4

    It says that indeed there is a feature to auto close tags. But I am not a programmer.

    Can you help me with the necessary code and where to put it as a child theme stuff to resolve my problem or is there something already in WordPress or the Theme to turn off auto close of tags?

    If there is a way to do it with CSS will be better because I have other sites with the same problem that use other Themes.

    • This reply was modified 2 years, 7 months ago by jetsystemservices. Reason: Add question
    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    On my Page Edit there is only <br> on each line. Somewhere during the rendering of the page those closing tags </br> are (auto)generated.

    The </br> tag is not a real HTML tag, so I’m not sure what would be generating it, and it’s certainly not the theme itself.

    It says that indeed there is a feature to auto close tags. But I am not a programmer.

    That Stack Overflow post is referring to something else. </br> is not a self-closing tag like <br /> – note the position of the slash. </br> and </img> are not actual HTML tags, they are not valid HTML.

    As a troubleshooting step to figure out how those bad tags are getting there, you could try ruling out a plugin conflict by temporarily deactivating all your plugins. Make a fresh post, without copy-pasting content from anywhere. Does the problem persist? If the problem is gone, reactivate your plugins one-by-one, look at the site in between each reactivation, to find the conflict.

    I think I found part of the problem or the actual problem cause.

    I had the code to make the page Responsive:
    (<div style= ... data-pneresponsivelayout="1">)

    When I turn of the Responsive mode the lines went to single line.

    So how do I make it Responsive but not making the lines double?

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Cerauno is already responsive, adjusting automatically to any screen size, so I’d suggest you try removing that code you added. That should do the trick!

    Thank you for the help

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    You’re very welcome!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Setting line-high’ is closed to new replies.