Support » Plugin: W3 Total Cache » Setting for webp functionality

  • Resolved honoluluman

    (@honoluluman)


    Hello 🙂

    In my site i am using your great plugin along with ShortPixel Image Optimizer and recently i have decided to use webp option for optimizing just my new images. For the image optimization i am using the <PICTURE> tag syntax but still i don’t get the webp images in front.

    For W3TC i am using page + minification + browser caching but i am not sure if there are any specific settings that i would need to look for not making any mistake from caching side.

    Could you give me a help please?

    Thank you very much

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @honoluluman

    Thank you for your inquiry and I am happy to assist you with this.
    W3 Total Cache does not impact converting the images to webp. Since the method, you are using the “” tag is replaced with a “<picture>” tag, after converting the images you should only purge the page cache.
    If the images are still not showing as webp, disable W3TC temporarily and see if the issue persists. If the issue is still there then, it’s not related to W3TC. If however, the images are served as webp after W3TC is deactivated, re-activated W3 Total Cache and disable the settings in Performance>General settings one by one, save all settings, and purge the cache after each option is disabled and see which one might be causing the issue.
    Thanks!

    Thread Starter honoluluman

    (@honoluluman)

    Hello @vmarko and thank you very much for your fast reply.

    There is no problem with webp functionality at the moment since i am not using CDN and i decided to use .htaccess method and everything works as expected 🙂

    Another and more important implementation that i would like to ask your help with please.
    On my site i am using pretty much the most common settings that are recommended. And i have disabled the page cache for logged in users (minification is enabled for logged in users).

    Since i already know which pages shouldn’t be cached, (and until now i haven’t experiencing any problems with my settings) i would like to cache the pages also for all roles of logged in users (except admin).

    Would it be possible to send you my settings and my site along with a test account so that you could understand and advice how i could implement this so that i don’t do any mistake?

    Thank you very much for your time

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @honoluluman

    Thank you for the information.
    It is highly recommended not to cache pages for logged-in users to avoid sharing any sensitive data.
    Please keep the cache disabled for logged-in users to avoid any possible issues.
    Thanks!

    Thread Starter honoluluman

    (@honoluluman)

    hello @vmarko thank you for your advice. Then i will keep it as it is.

    Regarding the webp i would like to clarify what i did. The image optimization plugin that i have decided to use specificaly for webp, has the option Browser Caching for WebP files (saving images in browser cache memory) and this i have decided to set it inactive.

    In W3TC on Browser Caching – Media & Other Files which i guess has to do with images, i have this set up.

    Should i also enable the option on the other plugin or not?

    Thank you very much for your help

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.