WordPress.org

Support

Support » How-To and Troubleshooting » Setting Featured Image hangs on saving

Setting Featured Image hangs on saving

  • We started to have this problem today when setting “Featured Images”. Once you select “Set image as featured image” the “saving” will hang. I have left this article open for 30 minutes and still the images do not save.

    I have noticed that a few people on here have had the same problem. I have also noticed that there is no solution. From what I have found.

    Thanks,
    Damian

Viewing 15 replies - 1 through 15 (of 20 total)
  • I fixed my problem by “Re-Installing” WordPress via the dashboard.
    I hope that fixes anyone else’s problem.

    Reinstalling didn’t work for me on 3.4.1. Anyone have a fix?

    My fabulous host, liquidweb, solved it for me. Here are the Tech’s comments:

    “I did find a few ModSecurity errors being tripped by the IP this ticket was created for. I have whitelisted the script causing the error.”

    amdcreations

    @amdcreations

    Update your installation to wordpress nightly built which is version 3.5
    http://wordpress.org/nightly-builds/wordpress-latest.zip follow manual update procedure. make sure you backup your website data. 🙂 i FIXED it!

    hope this info helps you all.. cheers

    tommcgee

    @tommcgee

    I’m using WP 3.4.2 in a multisite installation with a combination of subdirectories, subdomains and domains. It works in at least one of the subdomains, but not in the subdirectories or in the root blog.

    One thing I noticed that at least made it behave differently, in wp-admin/js/set-post-thumbnail.js Firebug was showing this line:

    action:"set-post-thumbnail", post_id: post_id, thumbnail_id: id, _ajax_nonce: nonce, cookie: encodeURIComponent(document.cookie)

    In the key value pair “post_id: post_id” it was interpreting the key as a variable instead of a string, so it was passing something like “71: 71”. I put quotes around the key, so now I see that the POST is actually populated the way it should be — it was empty before — but still the server isn’t responding.

    Here’s the form data sent to admin-ajax.php:

    action:set-post-thumbnail
    post_id:6
    thumbnail_id:198
    _ajax_nonce:51f75c019e
    cookie:a_bunch_of_stuff_I_shouldn't_post_here
    amdcreations

    @amdcreations

    I’m running multi-sites in subdirectories as well, after updating to wp 3.4.2 featured image stopped working. had to read forums and nothing helped me. so thought of trying out something on my own, which was updating it to a nightly built of wp version 3.5 it fixes the featured image issue and the interface is pretty cool. manual updating could take sometime if you’re not a technical guy.

    It’s an error in WP 3.4.3

    I have this problem too, I tryed to downgrade to 3.4.1 and the problem was not solved (or I was too stupid and I didn’t trash the browser cache before trying again).

    I also tryed WP 3.5 beta and it did not resolve the problem.

    I “resolved”: the problem is/was related to the plugin “wp e-commerce” ‘s product image current beta version.

    I had to downgrade to stable version and now it’s working again.

    Hope they fix this soon.

    Hm. I am not using that plugin.

    Fortunately there’s a workaround. I’ve found that whatever is the first image associated with a post becomes its featured image. So if I plan carefully I can still get the functionality, even though I lose the flexibility.

    Im having the same problem here too.

    It starts when I change my host from windows to linux.

    I cant upload new images too.

    Some suggestions?

    Did you check your permissions?

    But that’s a different problem.

    Yes tomm, about the uploads it was permissions. This was solved. Change all wp-content/ to 777, upload a file and back to 755.

    About the feature image, I install the Drag & Drop Plugin and it was solved.

    Tks!

    Lucke.stz – thanks for your suggestion, that works for me, too…

    the issue is, I am using the multiple featured images plugin and for those additional featured images it is not working…

    can’t wait for 3.5

    Drag & Drop for Post Thumbnails was just the ticket, thanks Lucke!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Setting Featured Image hangs on saving’ is closed to new replies.