• Resolved bsreverman

    (@bsreverman)


    Hi – I’m using the Woffice theme and am having trouble trying to add files to subdirectory. Subdirecotry shows up on list, and when clicked is see the main directory and the subdirectory over the table, but subdirectory does not show up in Destination Directory pull down menu. When I try to add files to subdirectory table using the fileup button I get a “Please build the path to your destination” message. I’m a noob sorry.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author thomstark

    (@thomstark)

    Show me your fileaway and fileup shortcodes. I’ll fix them for you.

    Thread Starter bsreverman

    (@bsreverman)

    Tom here are the short codes on the page using fileaway. Thanks.

    [fileaway base=”1″ makedir=”true” sub=”sub=”curriculum docs/” ” type=”table” directories=”true” paginate=”false” makedir=”true” flightbox=”images” manager=on]
    [fileup base=”1″ makedir=”true” manager=on]

    Plugin Author thomstark

    (@thomstark)

    You had some typos in your fileaway shortcode (sub=sub=curriculum docs). You had manager attribute in your fileup shortcode, which is not an attribute of fileup. You didn’t have the sub attribute in your fileup shortcode. I also added drawerid to fileaway and matchdrawer to fileup, so that whichever directory you’ve navigated to on your fileaway table becomes the upload directory.

    [fileaway base="1" makedir=”true” sub="curriculum docs" type="table" directories="true" paginate="false" makedir="true" flightbox="images" manager="true" drawerid="1"]
    [fileup base="1" makedir="true" sub="curriculum docs" matchdrawer="1"]

    @thomstark

    Can I DM you with screenshots to the issue I am having? Thank you in advance

    Thread Starter bsreverman

    (@bsreverman)

    Hi Thom – I inserted the shortcodes and get this message:

    File Up Admin Notice: The initial directory specified does not exist:
    /home/ararte/ararte.isb.bj.edu.cn/html/wp-content/uploads/resources/"curriculum

    My file manager shows that indeed there is a path …wp-content/uploads/resources/curriculum docs/

    Thanks for getting back to me so quickly.

    Plugin Author thomstark

    (@thomstark)

    Look at the error. It says ‘resources/”curriculum’. There’s obviously another typo in your shortcode.

    Watch out for smartquotes. Watch out for unclosed attribute values.

    Plugin Author thomstark

    (@thomstark)

    @ergoweb, yes.

    What’s the best way to DM you?

    Q: The main issue I am having now is that my file upload path and directory new path are somehow not the same. So I am uploading to a folder and those files are not showing up in the directory view of Fileaway. How is this possible if I have set both to dir 1 in settings?

    thank you

    Plugin Author thomstark

    (@thomstark)

    fileaway.plugin at gmail dot com

    Send your shortcodes, and tell me what type of server you’re running.

    I’m using the W Office theme and the built in FileAway Manager shortcode.

    Email sent – thank you

    Plugin Author thomstark

    (@thomstark)

    I don’t have the W Office theme and I don’t know how they implement my shortcodes, but several users have complained of issues using their built-in shortcodes. I suggest building the shortcodes manually. The screenshots you sent me don’t indicate any of the File Away options you might’ve selected when employing the W Office features. The shortcode attributes can be found in the File Away Attributes and File Up Attributes tutorials on the File Away settings tutorials tab.

    @ergoweb: What kind of server do you use. I’ve had some issues with the directory path under winserver 2008 and IIS.
    I can post the correct settings for this case tommorow.
    Greetings, Stefan

    • This reply was modified 7 years, 8 months ago by stefan.sp.

    I am almost 100% sure it’s Apache

    Plugin Author thomstark

    (@thomstark)

    ergoweb is using apache.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘setting directory path’ is closed to new replies.