Support » Requests and Feedback » Setting WP default email sender

  • By default when you send any notification from your blog (including many of the plugins as well) sender is “WordPress” and the sender e-mail address is wordpress@yourdomain.com.

    Why must we have to use a plugin or add filters to the functions.php file or edit the pluggable.php file to fix this? (according to the search results on this issue)

    Because most people won’t have an actual ‘wordpress@yourdomain.com’ email address any out going email will be flagged as spam or not make it to the destination at all. Most people new to WP won’t even know this is a problem or they simply don’t know how to fix it themselves.

    Seems that this should be a simple fix for the developers? Why couldn’t they have this in the WP settings? Or at least be able to set these two attributes in the wp-config.php file? Or asked and set during the WP install?

    • This topic was modified 1 week, 2 days ago by  Steve Stern.
    • This topic was modified 1 week, 2 days ago by  schulz.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    It’s meant to be not a real address, like noreply. Not having the address exist doesn’t automagically get it flagged as spam, though.

    I would have to disagree with Ipstenu statement.

    See: http://www.gettingemaildelivered.com/why-all-the-email-addresses-you-send-from-should-really-exist

    If WordPress developers are not going to ever fix this, then at least they could have it somewhere prominent in the documentation that creating a ‘wordpress@yourdomain.com’ email account would be a good idea (however I’d rather they fix it).

    I have to agree with Schulz. I’ve recentrly discovered that new comments notifications from WordPress never reach my Gmail address. However, if I change user address to some other email service, the notifications come though fine. They are obviously getting rejected by Gmail for some reason. I have a feeling that this is somehow related. Gmail probably identifies them as fake, because they do not even reach the spam folder.

    I actually think this is a bug. WordPress doesn’t set $auto to false when calling $phpmailer->setFrom() in the wp_mail() function. If $auto is true, PHPMailer will call its ::Sender() function, which sets the return-path header (“f” parameter) to the usually-invalid email address.

    An invalid return-path header is going to trigger a reject from Gmail, Outlook, and most ISP-based email providers. (Not setting the “f” parameter could result in the same problem. but in this case it’s the lesser of two evils.)

    There are several ways to fix this. The best is a rewrite of the (10-year-old) wp_mail() function, coupled with a new “Mail” option in dashboard Settings that sets how email is sent — and has support for SMTP. PHPMailer supports SMTP, WordPress is loading the SMTP support class, and it only takes five extra lines of code to send an email via SMTP.

    Heck, one could even parse the admin-supplied email address, and if its domain is the same as $_SERVER['SERVER_NAME'], default to the mail() function and set the return-path header to the supplied email address. Otherwise require SMTP credentials.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.