WordPress.org

Forums

WP Migrate DB
[resolved] set_time_limit and "headers already sent" errors when .sql download begins (4 posts)

  1. ajfleming
    Member
    Posted 11 months ago #

    Migrate DB is the only plugin installed and activated on a fresh install of WP 3.9.1 but I'm seeing errors when the download is initiated.

    Warning: set_time_limit() has been disabled for security reasons in /home/carisouv/public_html/wp-content/plugins/wp-migrate-db/wp-migrate-db.php on line 771
    Warning: Cannot modify header information - headers already sent by (output started at /home/carisouv/public_html/wp-content/plugins/wp-migrate-db/wp-migrate-db.php:771) in /home/carisouv/public_html/wp-content/plugins/wp-migrate-db/wp-migrate-db.php on line 775

    Warning: Cannot modify header information - headers already sent by (output started at /home/carisouv/public_html/wp-content/plugins/wp-migrate-db/wp-migrate-db.php:771) in /home/carisouv/public_html/wp-content/plugins/wp-migrate-db/wp-migrate-db.php on line 776

    Warning: Cannot modify header information - headers already sent by (output started at /home/carisouv/public_html/wp-content/plugins/wp-migrate-db/wp-migrate-db.php:771) in /home/carisouv/public_html/wp-content/plugins/wp-migrate-db/wp-migrate-db.php on line 777

    Warning: Cannot modify header information - headers already sent by (output started at /home/carisouv/public_html/wp-content/plugins/wp-migrate-db/wp-migrate-db.php:771) in /home/carisouv/public_html/wp-content/plugins/wp-migrate-db/wp-migrate-db.php on line 778

    Followed by a dump of the SQL in the browser.

    Checked my PHP config and safe_mode is off. Any advice on what I should look at next?

    https://wordpress.org/plugins/wp-migrate-db/

  2. Chris Aprea
    Member
    Plugin Author

    Posted 11 months ago #

    Hi ajfleming,

    This has been corrected in our development code and will be available in the next public release of the plugin.

    Apologies for the inconvenience.

    Cheers,

    Chris

  3. ajfleming
    Member
    Posted 11 months ago #

    Great! Thanks Chris.

    If any others read this befor the next public release, you can work around the problem by unchecking the Save file to your computer option, and then using the download link on the following confirmation page.

  4. arreguisergio
    Member
    Posted 11 months ago #

    I have fixed it commenting line 771
    //set_time_limit( 0 );

    is it ok?

Reply

You must log in to post.

About this Plugin

  • WP Migrate DB
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic