WordPress.org

Support

Support » Installation » [Resolved] Set which version autoupdate to

[Resolved] Set which version autoupdate to

  • odminstudios
    Participant

    @odminstudios

    Need to update wordpress 3.0.1 to 3.0.6

    Have some strange bug with wp_insert_post – ignores custom taxonomy. Hope newer version will work.

    Can only use Autoupdate (have neither ftp, nor ssh access). Server configuration does not support most current WordPress.

    Is there any way to specify version for autoupdate?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Jan Dembowski
    Volunteer Mod. & Brute Squad

    @jdembowski

    Can only use Autoupdate (have neither ftp, nor ssh access).

    Is there any way to specify version for autoupdate?

    Nope. If your requirements are for a specific version of WordPress then you need to speak with your hosting provider to get file access to your server.

    Once you get that access, updating from 3.0.1 to 3.0.6 is pretty trivial.

    http://wordpress.org/download/release-archive/
    http://codex.wordpress.org/Updating_WordPress#Manual_Update

    odminstudios
    Participant

    @odminstudios

    Provider gives ftp access.
    But the connection speed is too low – last time took about two hours to upload 8kb file(

    Think already found a solution:

    Altered function download_url() in wp-admin/includes/file.php

    added:
    $url=str_replace(‘3.3.1-partial-0’, ‘3.0.6’, $url);

    right before:
    $response=wp_remote_get($url,array(‘timeout’=>$timeout,’stream’=>true,’filename’=>$tmpfname));

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Set which version autoupdate to’ is closed to new replies.