Support » Plugin: CAOS | Host Google Analytics Locally » Set up wp cron job for gtag update

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    You mean the feature in CAOS?

    Just select gtag.js, save settings, and you’re good to go!

    Thank you for getting back to me.
    Amazing plugin.
    But I have to update the gtag manually with CAOS otherwise I have this message

    gtag.js hasn’t been updated for more than two days. Is your cron running?

    It was flagged to remove the script from wp cron. Maybe it is just that. Isn’t it?

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Yes, if you have the option ‘remove script from wp-cron’ enabled. Then the update script won’t run automatically.

    Uncheck that option. Save changes. And then click the update button once, so that the gtag.js is created and updated.

    The notice that it hasn’t been updated for more than two days should disappear, and the cron should run from now on.

    Perfect. Thank you.
    Have a great weekend 🙂

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    hi @johnstan3,

    No problem! Same to you! 😀

    johnstan3

    (@johnstan3)

    hi @daanvandenbergh

    is there a way to flush the CAOS cache?

    I’m working on the below website and there is an error that seems related to AO but maybe it is not. (checking CHROME developer tool)

    https://bit.ly/2YpBoHW

    I mean, we have completely removed that plugin but we still have issues with that css file.
    As the folder cache/caos-analytics/gtag.js seems realted to it I thought to take action cleaning the plugin cache.

    Is it possible?

    Thank you for your patience.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    I was getting a notice (yellow) in the console related to analytic.js, because my ad blocker was enabled. When I disabled it, the notice disappeared. Is you adblocker disabled or are you loading the site in a private/incognito window?

    johnstan3

    (@johnstan3)

    yes. you have reason but now I still have 2 red messages.
    But it is not about CAOS.

    Thank you very much for getting back to me.
    Best.

    johnstan3

    (@johnstan3)

    hi @daanvandenbergh

    we are working on this website https://bit.ly/2kafHsF
    and apparently on each of those page the script
    https://removals-10c95.kxcdn.com/wp-content/cache/caos-analytics/gtag.js?id=UA-78413833-1
    is loaded twice.

    The first time it’s a blocking script. The second time it has the async attribute.

    can you help us to fix it?

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    That’s really weird. Is the theme loading wp_head() twice?

    johnstan3

    (@johnstan3)

    Thank you for your answer. We do not see this issue.
    Our crawlers see everything normal apart that GA code repeated.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Could you share a screenshot of your settings? I’ve never heard of this issue before 🙂

    johnstan3

    (@johnstan3)

    neverminder

    (@neverminder)

    I have the same problem and I can’t find the option ‘remove script from wp-cron’ in the plugin settings.

    • This reply was modified 11 months ago by neverminder.
    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Hi @neverminder,

    Correct. I removed that option a few versions ago. If you enable it in the past, you need to remove the setting from the wp_options table in your database yourself, by running the following query in your database:

    DELETE FROM your_wp_options_table_name WHERE option_name = 'caos_remove_wp_cron';
    

    Of course you should replace your_wp_options_table_name with the name of your wp_options-table. By default it’s called wp_options, but it could differ per server setup.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Set up wp cron job for gtag update’ is closed to new replies.