Support » Theme: Twenty Seventeen » set-up the featured image: -it is too huge and too high on the page

  • say_hello

    (@say_hello)


    hi there good day dear Experts and user of the great theme 2017

    i am currently tryin to fix the height of the  featured image : it is huge on home page

    see the page: [ redundant link removed, use the link field ]

    tried to apply this code – but did not help yet – https://wordpress.org/support/topic/set-featured-image-is-huge-on-home-page/

    .post-39 .panel-image {
        background-size: auto;
    }
    @media screen and (min-width: 48em) {
       .post-39 .panel-image {height: 40vh;}
    }
    .post-258 .panel-image {
        background-size: ;
    }
    @media screen and (min-width: 48em) {
       .post-39 .panel-image {height: 40vh;}
    }

    no piece of code helped me to reduce the heigth and the width of the image.

    what would you suggest now!?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • say_hello

    (@say_hello)

    hi there good day dear Jan,

    many many thanks for the moderation and the help.

    guess that it is because of a CSS rule setting the height to a fixed value.
    In other words – i guess that it’s more than just only the size of the featured image height,

    We can say that this is because of the scaling of the image up to such and such a value.

    well i need to fix this.

    say_hello

    (@say_hello)

    hello dear All,

    just want to share this with you – in case some of you work on the same issues:

    …in the past few days i had two articles that were guiding me:

    this one: https://wordpress.org/support/topic/set-featured-image-is-huge-on-home-page/

    and this one: https://wordpress.org/support/topic/how-to-resize-featured-image-in-seventeen-theme/

    and i have gained alot frome this thread. slav1977 mentioned: you have to paste this text at the end of your css:

    
    @media screen and (min-width: 48em) {
    .panel-image {
    height: 175px;
    }}

    I set this for my page to this following – note px is pretty important

    
    .post-258 .panel-image {
        background-size: auto;
    }
    
    @media screen and (min-width: 48em) {
    .panel-image {
    height: 255px;
    }}
    

    note: – it is pretty important to mention

    
    height: 255px;

    to note it in px. seems to do the trick…

    this helped alot; thanks to Slav1977 in this thread: https://wordpress.org/support/topic/how-to-resize-featured-image-in-seventeen-theme/

    i am glad – and i have learned alot.
    wordpress it rocks

    greetings
    say hello 😉

    • This reply was modified 2 months ago by say_hello.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.