WordPress.org

Forums

Instagram for WordPress
[resolved] set up instagram for wordpress (37 posts)

  1. Reflectuk
    Member
    Posted 2 years ago #

    Hello,
    I recently installed the plug in instagram for wordpress and I am having problems to link it up with my wordpress. I have no experience and knowledge in designing a website/blog but I have designed my own and this is the last thing I need doing. Can you help?
    I have the userID and token code but am struggling. i'll look forward to hearing from you, thanks

    http://wordpress.org/extend/plugins/instagram-for-wordpress/

  2. INK361
    Member
    Plugin Author

    Posted 2 years ago #

    sorry for the latest issues and inconvenience I might have caused. @DaveE is correct: we're hitting Instagram's API authentication limit. Thanks a lot for the input and suggestions. I appreciate this very much.

    I have fixed the wordpress plugin to allow you to enter your own client information. This means you'll have to register a client so that you can use it without being limited by other users of the app.

    I need two more days to make this all nice and deploy it to wordpress. So by Sunday evening everything will be fine again.

    For the time being if things get urgent. You might wanna use this 'instagram gallery widget': http://ink361.com/#!/promote. Scroll down to the bottom off the page, specify how you would like it and click 'get code'. Then paste this code inside a widget box on your blog.

    Please stay tuned. When I have pushed everything to WordPress, I'll inform you all.

    Happy photo viewing!

    Jbenders

  3. Odelheim
    Member
    Posted 2 years ago #

    Hi, Any news about an update?

    I have tried all day to deploy your plugin to a multisite, and when i type in the client_id and Client_secret, I just get the following message in a pop-up:

    {"code": 400, "error_type": "OAuthException", "error_message": "Redirect URI does not match registered redirect URI"}

    Which can't be right, because I've followed your guide correctly, and the instagram developer api is not complaining about mismatching URI.

    My Website URL is: http://overspringshandlinger.bloggerslounge.dk

    My Redirect URI: http://overspringshandlinger.bloggerslounge.dk/wp-content/plugins/instagram-for-wordpress/authenticationhandler.php

    Am I doing something wrong? or does I simply just not work on a multisite. I am the admin of the multisite aswell, and I can't deploy the plugin to the frontpage neither! :(

    Thanks for the work.

    /Odelheim

  4. fishingreviewstv
    Member
    Posted 2 years ago #

    Now it no longer works since the client id info was added.

  5. majamaki
    Member
    Posted 2 years ago #

    I just updated the plugin to version 0.4 and I'm getting the same error as above.

    {"code": 400, "error_type": "OAuthException", "error_message": "Redirect URI does not match registered redirect URI"}

  6. lisamorosky
    Member
    Posted 2 years ago #

    Yep, same here. I updated to the new version today and I get the same error:

    {"code": 400, "error_type": "OAuthException", "error_message": "Redirect URI does not match registered redirect URI"}

    I've set up everything correctly - I think there's a plugin problem.

  7. INK361
    Member
    Plugin Author

    Posted 2 years ago #

    Hi all,
    I just pushed another change to fix the authentication issue. It should be fine now.

    Please let me know if it works for you.

    Sorry for any inconvenience caused.

    jbenders

  8. majamaki
    Member
    Posted 2 years ago #

    Looks like its working now, thank you for the update.

  9. Odelheim
    Member
    Posted 2 years ago #

    Yeah, it seems to be working now. Thanks alot.

    It is possible to make it display more than one picture at a time?

  10. gilbertmc
    Member
    Posted 2 years ago #

    It doesn't work for me. I updated the plugin and checked all info and it doesn't work.

  11. damoxn
    Member
    Posted 2 years ago #

    I have the same problem after update.
    Should be the filename "authenticationhandler.php" specified in the redirect url or not?

  12. INK361
    Member
    Plugin Author

    Posted 2 years ago #

    damoxn, yes, thats the file that handles the authentication. Did you read the instructions? It gives a hint to what the redirect_uri should look like.

  13. damoxn
    Member
    Posted 2 years ago #

    Oh, now it works!

    I didn't change anything, saved the widget again and it runs.
    Maybe it takes a bit until the new client works?

    Thx a lot

  14. gilbertmc
    Member
    Posted 2 years ago #

    I reset the secret key, check everything and it still doesn't work.

  15. INK361
    Member
    Plugin Author

    Posted 2 years ago #

    What happens if you copy the redirect_url and paste it into your browser url bar? If it says 404 page not found or something alike, there is a misconfiguration.

    It should look something like this:
    http://websiteurl/wp-content/plugins/instagram-for-wordpress/authenticationhandler.php

  16. oriontool
    Member
    Posted 2 years ago #

    When I go to http://www.vernleavell.com/wp-content/plugins/instagram-for-wordpress/authenticationhandler.php

    It says: An error occured

    Type:
    Message:

    Please make sure you entered the right client details

    However I have followed your instructions. Please help..

  17. gilbertmc
    Member
    Posted 2 years ago #

    I set the permissions to 777 and it still appears that message.

    Isn't it better to just login with Instagram account, allow access and that's it?

  18. seanwroe
    Member
    Posted 2 years ago #

    i am still having issues.

    i still get {"code": 400, "error_type": "OAuthException", "error_message": "Invalid Client ID"}

    I tried to figure out what the other threads have done, but couldn't figure it out

  19. INK361
    Member
    Plugin Author

    Posted 2 years ago #

    That URL is only supposed to be accessed after you fill in the correct client_id and client_secret into the widget configuration. It will give an error if you just access it like that.

    When it says Invalid Client ID, it means the client_id is not properly configured in the instagram client management console. Did you follow instructions on how to make it? Make sure there are no spaces around the values you enter.

    I think I didn't work out the instructions well enough, ill fix them tonight to be more detailed.

  20. oriontool
    Member
    Posted 2 years ago #

    The instructions are pretty clear. I followed them to the letter(no spaces) and it still does not work. Hope you can fix this.

  21. INK361
    Member
    Plugin Author

    Posted 2 years ago #

    I have created a new version that has increased error reporting when invalid client_id and client_secret values are entered. Could you see how this works for you?

  22. gilbertmc
    Member
    Posted 2 years ago #

    That's the error that appears to me after updating the plugin:

    An error occured

    Type:
    Message:

    Please make sure you entered the right client details

  23. oriontool
    Member
    Posted 2 years ago #

    Nope, still not working. :(

  24. oriontool
    Member
    Posted 2 years ago #

    Anyone have any ideas on this?

  25. seanwroe
    Member
    Posted 2 years ago #

    I have sorted out the client id and client secret.
    I now don't get an error, but i still don't get any instagram on my website any ideas?

  26. gilbertmc
    Member
    Posted 2 years ago #

    Isn't it easier to use login and password?

  27. mariambn
    Member
    Posted 2 years ago #

    I cant get the client_ secret code from Instagram, the instructions which is listed in the pop-up window is not valid.

    There's the button which says "manage clients" but then there's nothing which sayas "Register a New Clien" the page only gives you this option (Interested in trying out the Instagram API?) which is for instagram developers and too much complications!

  28. gilbertmc
    Member
    Posted 2 years ago #

    So as I see the best solution is to uninstall the plugin and find another one? No solution given?

  29. INK361
    Member
    Plugin Author

    Posted 2 years ago #

    You'll need to make sure that your browser is not blocking the authentication popup from Instagram once you have saved your client ID and client secret in the widget settings.

    Once you have clicked save a window will open asking you to authenticate your website.

    As for creating your instagram client please visit this page:

    http://instagram.com/developer/clients/manage/

    In the top right hand corner will be a button that you can click on to register your client.

    Unfortunately due to the popularity of this plugin you have to sign up for your own instagram API client in order to use it correctly. Please follow the instructions in the popup regarding the settings you need to enter into the registration form.

  30. gilbertmc
    Member
    Posted 2 years ago #

    Now it works! thank you jbenders for solving the problem :) And sorry if I was arrogant

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Instagram for WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic