Support » Fixing WordPress » Set Static Home Page and Blog page in WordPress 3.3

  • Resolved labellush


    So it looks like the option (under “Reading” in the control panel) to set a static home page and seperate blog page in WordPress 3.3 has been removed.

    Now by default the website’s index page wants to display the blog, and I can’t seem to find an easy way to go about changing this.

    Does anyone have any insite on this?

    Hoping so…thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator kmessinger


    It was not removed. It should be there.

    [edit] Unless you are not signed in with admin rights.

    Nope, I’m having the same problem as labellush and I’m an admin (and the only user on my site).

    [update] Works fine with a clean install on a test domain, though. Guess I’ll install plugins one at a time until the feature breaks.

    [update] Just installed all the same plugins on the empty test site that I have on my broken site; didn’t break anything. I assume it’s something that happens when you upgrade to WP 3.3.

    Moderator kmessinger


    metahack – adding on to a resolved post is an almost guarenteed way to NOT get an answer.

    Pls start your own thread as per

    kmessinger – Thanks, but I wasn’t necessarily expecting a technical solution, I just wanted others who stumbled on this post as I did (it was the top Google search result) to be aware that while this thread may have been closed, this issue is not resolved.

    Hi, so I closed this thread because I thought it was just me… My issues was resolved (not quite sure how). I am the only user on the account, and I have admin rights – so for me that was not the cause. When I checked back after receiving the first response on this thread the options had reappeared under reading – I assure you it was not there before.

    As for what caused it to reappear, some of the things I tried that might have affected it include:

    1. Created multiple pages to provide landing page options. I think I did this in the beginning before looking at the Reading page but I could be wrong – It would make sense that you would have to create pages before you could select one. Either way make sure you create multiple pages.

    2. Switching the theme several time (switched back to my original in the end).

    3. Logged in and out of the account after creating pages.

    These suggestions might sound stupid – but I didn’t do anything fancy and as I said all of a sudden it was fixed and is working fine now.

    Good luck with your site!

    Awesome, I added a page and then downloaded and activated the “Easel” theme; the problem went away and now the static home page option is back in my original theme! Thanks.

    Glad it worked!

    I had a similar issue which is how I found this topic.

    I just added a page under pages and it came back. Thanks!

    Try to have more than 1 page on your site.
    The reason? – it couldn’t find at least 2 pages on your blog.

    If you do a fresh install of wordpress, the option will not show unless you create another page (a total of 2 – one is the sample page and the other one is the new page)

    Good luck!

    I need to have all the pages as static pages in wordpress. I do not want the leave a comment thing anywhere………NEED HELP



    Forum Moderator

    @manaal: As per the Forum Welcome, please post your own topic. Your problem has nothing to do with the original topic.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Set Static Home Page and Blog page in WordPress 3.3’ is closed to new replies.