Support » Plugin: All In One WP Security & Firewall » Set recommended file permission doesn’t work

  • Hi,

    When I use the plugin and go to “File Permissions”, normally you should be able to set recommended file permission, by simply clicking on the button “set recommended file permissions”. Unfortunately this doesn’t work..
    Could you please tell me how to solve the problem? And how can I set the recommended file permissions?

    Thanks in advance!

    Kind Regards, Nick

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, what kind of server is your site hosted in? This will allow us to advice you further.

    Regards

    Plugin Contributor chesio

    (@chesio)

    Hi Nick,

    I’m afraid you’ve came accross this known bug in AIOWPSF.

    Can you confirm?

    Plugin Author wpsolutions

    (@wpsolutions)

    @mannenbox11,
    If you are on a windows server or similar system, then the file permissions feature will not apply to you because it is specifically for unix-type permissions settings. I think I might add a message in that settings page to highlight this.

    @chesio,
    thanks for the reminding me about that bug. I will try and look into this and apply a fix.

    • This reply was modified 1 year, 6 months ago by  wpsolutions.
    • This reply was modified 1 year, 6 months ago by  wpsolutions.

    Hi,

    Thanks for the replies!

    @mbrsolution: Can you specify what kind of info you need with regard to the server? My hosting provider is Sohosted.com. Is that the info you are looking for?

    @chesio: I’m afraid it’s not the same problem; none of the file permissions change. When I click on “set recommended file permissions” there’s a message “The permissions for […] were succesfully changed to 0644”, but the file permissions are simply not changed. Also not another / a wrong file..

    Do you have any suggestions?

    Thanks in advance!

    Regards, Nick

    @wpsolutions: thanks for your reply. So does that mean I can’t change the file permissions to extra secure my website?

    Regards

    JacobD10

    (@jacobd10)

    Still seems there is no warning about this. I had to come looking for why this was happening.

    Is it possible to add a file permissions check/scan for Windows based systems?

    Plugin Contributor mbrsolution

    (@mbrsolution)

    @jacobd10, are you referring to adding a file permission check system for IIS servers?

    JacobD10

    (@jacobd10)

    Windows Server OS running Apache. It won’t set permissions. I also see the same issue as the GitHub link posted above.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Thank you for adding more information. I have submitted a message to the developers to investigate further your request.

    Kind regards

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi,
    I have added a check in the code which will removed those settings if a Windows server is detected because this feature is not applicable in such cases.
    This change will be available in the next release.

    JacobD10

    (@jacobd10)

    Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Set recommended file permission doesn’t work’ is closed to new replies.