WordPress.org

Forums

W3 Total Cache
"Set expires header" option, in browser settings is disabled (20 posts)

  1. ilieg
    Member
    Posted 1 year ago #

    Hi,

    I am using the W3 Total Cache plugin on a multi site WordPress install.

    For some reason I the "Set expires header" option, in browser settings is disabled. I cannot click on the checkbox to enable it.

    I've made sure mod_expires is enabled, and in .htaccess I made the edit below but still that checkbox will not become enabled so I can click it.

    <ifmodule mod_expires.c>
        ExpiresActive on
    </ifmodule>

    Any help pointing me in the right direct would be appreciated.

    Thank you.

    https://wordpress.org/plugins/w3-total-cache/

  2. lacauserie
    Member
    Posted 1 year ago #

    Hello,

    We have the same issue here.
    I cannot click on any of the checkboxes "Set expires header" on de Browser Cache page.
    All other checkboxes are "clickable"

    Thank you for any help.

  3. diegosalcido
    Member
    Posted 1 year ago #

    Got the same issue in one domain on a dedicate server, that have other domains with "Set Expire Headers" available, but in one of them the option its greyed out.

    ¿Any Guess?

  4. Can
    Member
    Posted 1 year ago #

    No problem here with the latest version of the plugin and WordPress.

  5. melashcott
    Member
    Posted 1 year ago #

    Ahhh - Same problem for me... at http://www.scottmorton.com.au
    Would be great to get an answer for this one if possible?

  6. diegosalcido
    Member
    Posted 1 year ago #

    Just triple check again in the same server with the same settings on each domain, same wp version 3.9 same plugins w3tc 0.9.4, only one of my sites the oldest one doesn't allow me to select "Set Expires Header" its disabled, please Frederick Townes, help us with this issue.

  7. diegosalcido
    Member
    Posted 1 year ago #

    ¿Anybody with a fix?

  8. Tschoepler
    Member
    Posted 1 year ago #

    Same here: WordPress 3.9, single-site, w3tc 0.9.4, PHP 5.4.25. Other installations on the same server, same setting work just fine (multi and single site). But this site is the only one using CDN (CloudFront/Pull). But disabling CDN doesn't help either. Also my mirrored dev version of the site works fine. This is also my oldest wordpress installation, like diegosalcido mentioned before.

    tschoepler.net

  9. Tschoepler
    Member
    Posted 1 year ago #

    Edit: Same problem on my mirrored dev site. Though when I activate WooDojo Maintenance Mode the option gets available.

  10. fuflo
    Member
    Posted 1 year ago #

    For some reason w3tc disables the checkbox'es when CloudFront cdn is selected in the cdn options. Even if the cdn option itself is off.

    So a solution is to change the cdn type to some other besides CloudFront and the checkboxes are enabled again.

  11. lacauserie
    Member
    Posted 1 year ago #

    So, is it a bug? Any information from W3total?

  12. fearnowrath
    Member
    Posted 1 year ago #

    This i have seen to arise mainly due to conflicts with other plugins. I had experienced it once before a long time ago.

  13. wayne20
    Member
    Posted 1 year ago #

    I've got the same "untickable" set expires header on several sites but I'm using CloudFront as well. Not sure that Cloudfront is the issue but this sure is frustrating.

  14. Max
    Member
    Posted 1 year ago #

    This is likely because W3TC's author read the CloudFront documentation. Specifically CloudFront state in their documentation:

    We recommend that you use the Cache-Control max-age directive instead of the Expires header field to control object caching. If you specify values both for Cache-Control max-age and for Expires, CloudFront uses only the value of max-age.

  15. vignesh676
    Member
    Posted 1 year ago #

    For some reason w3tc disables the checkboxes when CloudFront cdn is selected in the cdn options. Even if the cdn option itself is off.

    So a solution is to change the cdn type to some other besides CloudFront and the checkboxes are enabled again.

    This solution works. after changing the CDN type clear all cache and then set expires header option gets enabled. Thanks to solution from fuflo.

  16. jakobde
    Member
    Posted 8 months ago #

    Anybody found a solution or a workaround to this yet? I.e to enable browser caching together with cloud front?

  17. varange
    Member
    Posted 8 months ago #

    Yes, I had the same problem and the fixes suggested by vignesh and others works just fine. Jakobde: learn to read.

    Thanks for posting a fix!

  18. jakobde
    Member
    Posted 8 months ago #

    Thanks for point that out to me Varange but since i can't read no offense taken i guess. I also guess that in your world everybody have English as their mother though and that all plugins behave the same way on all the world's word press installations. Since your reading capability seems to outperform my own could you please explain how i can have both Cloud front enable together with expires header setting? As this was my question.

  19. kamal.asawara
    Member
    Posted 6 months ago #

    ‘Add expiry header’ and ‘Cloud front CDN’ cannot be activated together because W3 cache not able to add expiry headers to cloud front servers.

  20. jakobde
    Member
    Posted 6 months ago #

    @Kamal: du you know if there is any workaround for this i.e. to enable browser caching? As both Pingdom and Yslow says that browser caching is off when no expiry header is set :-(

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.